Adding the email field to a filter in the Contact Search Centre makes it impossible to save that filter.

Version 1

    Details

    Adding the email field to a filter in the Contact Search Center makes it impossible to save that filter.

    [STEPS TO REPLICATE]
    1. Open the Contact Search Center
    2. Search By 'E-Mail'



    3. Click the Save button

    [RESULTS]
    The options to 'Save as Filter' and Save as Group' are shown inactive







    Resolution

    [CAUSE]
    Filters can only but built using Contact1 and Contact2 fields, as the E-mail address is stored in the Contsupp table you are unable to build a filter using this field therefore the option to 'Save as filter' and 'Save as group' is disabled in the contact search center when you search on E-mail.

    Other 'search by' fields that also have this restriction are:
    Notes
    Name (Additional)
    Contact (Primary or additional)