GoldMine Web (GMWEB) - HTTP Error 404.0 Not found - IIS error: Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case sensitive.  Source Error:  Line 231:  <compilation debug="true" targetFramework="4.0">

Version 1

    Details

     

    When browsing to GoldMine Web getting

    HTTP Error 404.0 Not Found -
    The  resource you are looking for has been removed, had its name changed, or  is temporarily unavailable

    Module IIS Web Core
    Notification MapRequestHandler
    Handler Static file
    Error Code 0x80070002



    After turning off custom IIS errors via
    \Program Files (x86)\GoldMine Connect\Web.config, set "customErrors defaultRedirect="~/Views/Shared/Error.aspx" mode="On"" to mode="Off" to get the more descriptive error


    Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case sensitive.

    Source Error:  Line 231:  <compilation debug="true" targetFramework="4.0">



     


    Resolution

    [CAUSE]
    The GMMObileApplicationPool is using a .Net version other than v4.0

    [RESOLUTION]

    1.  In IIS Manager, Open server name, and highlight Application Pools
    2. Highlight GMMobileAppPool, and click Advanced Settings on the right
    3.  The very first parameter is .NET Framework Version
    4.  It should be set to v4.0
    5.  If it's not, click the version number, click the down arrow, and select v4.0



    6.  Click OK
    7.  Restart IIS for example from IIS Manager or in an administrative  command prompt, enter IISRESET, and hit Enter
    8. Verify by browsing to the GoldMine Web page