GMME Loading error: Error, failed to get the contact list. This error occurs when opening a contact record on a device or Safari browser

Version 1

    Details

     

    Scenario:
    1. Open a Safari web browser (or log in to GoldMine Mobile on any supported  device)
    2. log in to GMME
    3. Tap Contacts
    4. Select All Contacts (happens also on  any other kind of contact list via GoldMine Mobile)
    5. double click on any  contact record
     
    Result:  
    error message pop-up:
    Loading error: Error, failed to  get the contact list.

     
     

     


    Resolution

    [CAUSE]
    - This error is normally  associated with a data mismatch between the CONTACT2 table and the CONTUDEF  table.

    - The related log file (GMConnect.Log since GoldMine 2014.2) provides further related information and often gives also the more detailed reason for example 

    2015-05-10 16:20:17,423 - [ERROR] Thread id[39] - GoldMine.Models.ApplicationExceptions.ClientInformationException: Error, Run SQLcollation statements error.,
    System.Data.SqlClient.SqlException (0x80131904): Invalid column name 'UAB'.
    Invalid column name 'USURTA'.

    [STEPS TO RESOLUTION]

    Run GoldMine maintenance to align the CONTACT2 and CONTUDEF  tables.

    NOTE: Please make sure you backup your database and Log all users  out of the system before you run the rebuild process.

    1. Log ALL users  out of GoldMine
    2. Close any application that has an external link to  GoldMine (e.g. Microsoft Word, Microsoft Outlook or Microsoft Excel)
    3. Stop  IIS
    4. Open GoldMine with master rights
    5. Tools > Databases > Maintain Databases
    6. Current Contact Set files > Next
    7.  Tick the Option for Rebuild and Pack (ignore the upcoming message that this is  usually not necessary for Microsoft SQL databases) > Next
    8. Finish
    9.   Restart IIS
    10. Verify the behavior in GoldMine Mobile