When trying to load GoldMine Mobile you receive an unhandled win 32 exception error followed by Error, failed to Set loading State or Error Failed to sign in when loading GoldMine Mobile

Version 1

    Details

    When trying to log in to GoldMine Mobile you may receive A visual studio just-in-time debugger error message like the one below

    An unhandled win 32 exception occurred in w3wp.exe [4692].



    - Clicking No, Cancel debugging then returns the below error in the web browser that you are trying to log in to GoldMine Mobile in

    Error, Failed to get loading state.



    - If you are running an older version of GoldMine Mobile than 2014.2 you may receive the below error message

    Error, Failed to sign in



    Resolution

    [Cause]
    - This error can be caused by running GoldSync as a Windows Service or the GoldMine messaging Service on the same machine that GoldMine Mobile is published through IIS on.
    - This is RM # 215322

    [Resolution]
    - Where possible we would not recommend that GoldSync be installed on the same server that is running GoldMine Mobile.
    - If this is unavoidable then the simple resolution is to make sure that IIS is started before the GoldSync Service.

    1. Stop IIS
    2. Stop the GoldSync Service \ GoldMine Messaging Service
    3. Start IIS
    4. Log in to GoldMine Mobile
    5. Log out of GoldMine Mobile
    6. Start the GoldSync Service \ GoldMine Messaging Service
    7. Log back in to GoldMine Mobile to verify that it still works.

    Note: Some 3rd party applications may also cause the same issue, for Example IntelliClick and W-Mobile.