GoldMine Mobile (GMME) - When the Lastname field is removed from the Primary field view(s), My Contacts in GMME remains blank.

Version 1

    Details

    GoldMine Mobile (GMME) - When the Lastname field is removed from the Primary field view(s), My Contacts in GMME remains blank.


    [STEPS TO PREPARE]
    - Global Support suggest you use a demo data base

    A. Customization
    1. Log in to GoldMine with a master user.
    2. Tools > Configure > Record Types
    3. Expand Primary Field Views
    4. Right Click on Main View > Clone
    5. Name = Main2
    6. Enter (a new Primary View Main2 will appear in the list)
    7. Highlight the view Main2
    8. In the right upper pane > Click  on the column DB Name (this will sort the list alphabetically)
    9. Highlight the row with LASTNAME  > Right click > Delete > Confirm the deletion



    10. Expand the Record Types
    11. Right Click on Other record type > Edit
    12.  Select in Primary Field View > Main2 from the  drop down list, everything else can  be left as it is
    13. OK
    14. Repeat Steps 10. - 13. for all available Record Types
    15. In the Record Types Administration Center's Toolbar > Apply changes icon (last icon in the row)



    16. Reset IIS

    B.
    Ownership
    - Make sure that the testing non-master user is owner or member of the owner group for several customers

    1. Browse to Art Bardtoll (in the demo database)
    2. Edit > Record-related Settings
    3. Ownership Tab
    4. Set Ownership to the non-master user or to a group where the non master user is member

    [STEPS TO REPRODUCE]

    In GMME
    1. Log on as the non-master user
    2. Contacts Tab
    3. My Contacts

    [RESULT]
    -
    Blank list although there are records in the non master user's ownership






    Resolution

    [CAUSE]
    - The missing LASTNAME field on the primary field view(s) is causing this behavior
    - This is logged as RM # 229169

    [WORKAROUND]

    Put the LASTNAME field back on all primary views where it is missing
    1. Make sure to have a full running backup of the GoldMine database
    2.  Although technically not necessary it would be recommended that this is  done while no one is logged into GoldMine Premium Edition
    3. Log in with Master rights
    4.  On a contact record in the top part, verify that on the current  view contains the field LASTNAME. If this is not included then
    a. Right Click > New Field (this opens the screen designer and at the bottom right the Place Field window)
    b. Open the drop down and scroll down to the LASTNAME field
    c. OK
    d. The field LASTNAME appears usually in the middle of the screen (might be in the Fields tab)
    e. Drag the LASTNAME field to the primary view
    f.  Double click on it, this will open the Field Properties dialog  (if applicable make some changes for example to rename the label etc)
    g. OK

    5.  Right Click in the top part of the Contact record (Primary View) > Select Primary Fields > Select the next Primary view in  the list
    6. Repeat step 4. (and if applicable 4.a.-4.g) and step 5.

    In the end the LASTNAME field needs to be back on all available primary screens
    7. Exit the Designer
    8. Restart IIS
    9. Verify the behavior in GoldMine Mobile.