Error when running reports: "Could not impersonate user for data source 'SaaS'".

Version 1

    Details

    Error when running reports: "Could not impersonate user for data source 'SaaS'".  


    As shown below, this will also cover the error "User ... does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account COntrol (UAC) restrictions have been addressed", when attempting to access localhost/Reports, on the report server.

     


    Resolution

     

    To fix the primary error, you will need to go to localhost/Reports, on the machine where SSRS is located:


     


    You will need to open the workspace, and open the Data Source, and within the Data Source, click on "Folder Options".  You will primarily need to make sure that you have either entered valid stored credentials (and selected "Impersonate the authenticated user" if appropriate), or select "Use Windows Integrated Security", if it's what you should be using.

    While you are here, it would be pertinent to ensure that under Security, your service account has the appropriate permissions to Browser, author/edit, and publish reports.

     

    Note: If launching localhost/Reports and logging in with the appropriate user, you receive the error "User ... does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account COntrol (UAC) restrictions have been addressed":



    This error is caused by Windows UAC. To work around this, perform a Run as Administrator on Internet Explorer.  Note that you may actually have to find the folder where “iexplore.exe” is located, and do a Run As Administrator on the executable directly.