A permission error returns if customer selects a service request template with the name in German

Version 1

    Details

    User gets an error message if a Service Request is create by selecting the type of request before selecting the customer.

    Error message:
    " Username ist nicht berechtigt, das ServiceName Request Offering zu beantragen".

    English translation:
    Username does not have the permissions/privileges to request the ServiceName service.

    [ STEPS TO REPRODUCE ]
    1) Logon to Smart Client using admin/manage, choosing English as language
    2) Open Request Fulfilment Workspace
    3) Create a new Service Request, choosing 'Desktop Computer Loaner" as the template (don't fill in the 'Customer' field at the top of the screen at this point)
    4) Fill in 'IT' as the department, 'Ed Trout' as the Requester, and 'Test' as the Primary Purpose and Additional Requirement.
    5) Now select Bob Levitt as the Customer at the top of the screen - this causes no errors.
    6) Close the window (don't save the Service Request), and close Smart Client
    7) Logon to Smart Client using admin/manage, choosing German as language
    8) Repeat steps 2) to 5) (the Service Request template is called "PC Ausleihen" in German).

    [ RESULTS ]
    ( Expected Results )
    It should be possible to select Bob Levitt in the German version, as it was in the English version.

    ( Actual Results )
    Upon selecting Bob Levitt, get an error saying that Bob Levitt doesn't have the permissions/privileges to request the PC Ausleihen service.


    Resolution

    Root Cause:
    Full-text search cannot match German word if the language for word breaker set as English.

    Steps to fix the issue by setting correct language for word breaker in full-text index
    1. Open Microsoft SQL Server Management Studio.

    2. Connect to the database and find table ServiceReqTemplate

    3. Right click the table and select Full-Text index -> Properties

    4. Select Columns page. You will see that all the fields's language setting for word breaker are set to English

    5. Set correct language as follow (e.g. field called "description"):
    -> for the default column "Description" leave English
    -> for "Description_de" set German
    -> for "Description_es" set Spanish
    -> for "Description_fr" set French
    -> for "Description_pt_BR" set Brazilian

    6. Click OK.
    7. repeat for every column of a localized field