Error when using Google Maps and Google Directions GM+Views message: You seem to be using an unsupported browser

Version 7

    Details

    Google Maps and Google Directions GM+Views message: You seem to be using an unsupported browser

    - As the behavior will not appear with default settings when Internet Explorer 10 or 11 is used on a system, the steps to prepare will simulate the behavior on those systems.
    - The behavior is always replicable on systems where Internet Explorer 9 or even lower versions are used. 

    [STEPS TO PREPARE]
    1. Open Internet Explorer
    2. Open either https://www.google.com/maps/ or https://www.google.com/maps/dir
    3. At the bottom right you will see either
    a. (this would be the default) that Google Maps / Google Directions is used in Full mode and you can switch into Lite mode



    b. that Google Maps / Google Directions is used in Lite mode and you can switch into Full mode



    4. for the steps to reproduce the Google Maps or Google Directions web site needs to be set on Lite mode

    [ADDITIONAL NOTE]
    - On systems with Internet Explorer 9 installed, Google Maps or Google Directions will be always only available in Lite mode


    [STEPS TO REPRODUCE]
    1. Browse to any Contact record
    2. Browse to the GM+View tab
    3. From the drop down select either Google Maps or Google Directions

    [RESULT]





    Resolution

    [CAUSE]
    - The underlying Internet Explorer interpreter for GoldMine 'mshtml.dll' is using Compatibility mode by default, which will cause the behavior in most cases. This is logged as RM # 233256.
    - It is definitely also recommended to verify if the the Lite mode of Google Maps/Google Directions is causing this behavior within GoldMine (further information about the Google Maps Lite mode, please refer to https://support.google.com/maps/answer/3031966?hl=en)
    - Internet Explorer 9 will start Google Maps or Google Directions always and only in Lite mode without having the possibility to switch to Full mode.
    - On newer Internet Explorer versions the user does have the possibility to set manually Google Maps or Google Directions in Lite mode.


    [STEPS TO RESOLVE/WORKAROUND]

    A. If switching to the Google Maps /  Google Directions Full mode is possible
     
    1. Open Internet Explorer

    Additional Note:
    while on systems with Internet Explorer 11 the switch between Google  Maps / Google Directions usually has direct impact and no further  actions should be necessary, especially on systems with Internet  Explorer 10 it has been recognized that
    the Cache from Internet  Browser needs to be cleared, resetting Google Maps / Google Directions to Full mode again via > Tools (ALT+X) > Internet  Options > Browsing History > Delete Button > Select  Temporary Internet Files and Website Files + Cookies and Website data > Delete .

    2. Open either https://www.google.com/maps/ or https://www.google.com/maps/dir
    3. At the bottom right, switch back to the Google Maps / Google Directions Full mode
    4. Close Internet Explorer
    5. Within GoldMine > Browse to any Contact record (It might be necessary to restart GoldMine)
    6. Browse to the GM+View tab
    7. From the drop down select either Google Maps or Google Directions again

    B. Use an alternative GM+View which opens the Google Maps /  Google Directions with the related Contact data in a browser window

    - Wherever a switch to the Full mode or the above steps not lead to resolve the behavior, alternative GM+Views for Google Maps / Google Directions can be downloaded from the attachments and setup within the GoldMine system

    - In GoldMine Premium Edition lower than 9.2.0 these GM+Views need to be created manually
    1. Download the attached text files <<Google Dir. Lite.txt>> and <<Google Maps Lite.txt>> and open it with Notepad.
    2. Log in with Master rights.
    3. Web > Setup GM+View.
    4. New Button
    5. Template Name for example Google Maps Lite or Google Maps IE9
    6. Click into the body
    7. Click the Icon <H> from the Toolbar
    8. Copy and paste the content of one matching text file
    9. Icon <H> from the Toolbar
    9. Icon Save (yellow disk) from the Toolbar
    10. The content should come up and a text should appear in the window


    11. On a contact record > GM+View and select and test the new created GM+View

    - In GoldMine Premium Edition 9.2.0 and higher these GM+Views can either be created manually by above steps or imported 
    1. Download the attached text files <<Google Dir. Lite.txt>> and <<Google Maps Lite.txt>> and rename only their file extension from txt to html
    2. Log into GoldMine with Master rights
    3. Web > Setup GM+View
    4. Import Button
    5. Browse to the desired HTML file (for example: Google Maps Lite.html)
    6. A message appears that the template was imported successfully
    5. Repeat steps 3.-5. for the other template you want to make available for your users
    7. OK