Automated process Execution dialog, 'Attach Process to selected contacts:' drop down list does not show the Process Code.

Version 1

    Details

    Automated process Execution dialog, 'Attach Process to selected contacts:' drop down list does not show the Process Code.

    [STEPS TO REPRODUCE]
    - Global Support recommend using a demo database
    - Scenario's 1 - 3 shows the 'Attach an Automated process' Dialog where the code field is shown
    - Scenario 4 shows the Automated process Execution dialog,  'Attach Process to selected contacts:' drop down list where the code is not shown.

    SCENARIO 1:
    1. Log in as a user with master rights
    2. Browse to any contact record
    3. Browse to the contact record's Process tab
    4. Right Click > Attach a Process
    5. Review the window if the Automated Processes list contains the assigned automated process Code For Example [MKT] Customer Welcome

    [RESULT]



    - The window is always a dialog with the Code, Process Name and  User information (depending if the AP is allowed to be manually  attached)

    SCENARIO 2:
    1. Log in as a user with master rights
    2. Browse to any contact record
    3. Tools > Automated Processes > Assign a Process
    4.  Review the upcoming window if the Automated Processes list contains the  assigned automated process Code for example [MKT] Customer Welcome

    [RESULT]



    - The  window is always a dialog with the the Code, Process Name and  User information (depending if the AP is allowed to be manually  attached)

    SCENARIO 3:
    1. Log in as a user with master rights
    2. Tools > Automated Processes > Manage Processes
    3. Select from the user drop down > (public)
    4. Expand the '[MKT] Customer Welcome' process
    5. Right Click on P 10 - If Address is valid, go to 110 > New
    6. In the Welcome to the AP Event Wizard > Enter any Event Description > Next > Next > Next
    7. In the (Perform) Action window > Select from the drop down Add a New process > Options Button
    8.  Review the window if the Automated Processes list contains the  assigned automated process Code for example [MKT] Customer Welcome

    [RESULT]



    - The window is always a dialog with the the Code, Process Name and  User information (depending if the AP is allowed to be manually  attached)


    SCENARIO 4:
    1. Log in as a user with master rights
    2. Tools > Automated Processes > Execute Process
    3. Activate at the bottom > Attach Process to  selected Contacts
    4. Open the drop down for the available processes
    5.  Review the upcoming window/list if the Automated Processes list contains the  assigned automated process Code for example [MKT] Customer Welcome

    [RESULT]



    - The information  is provided as a list without a specific dialog window, the list contains all automated processes from all users.


    Resolution

    [CAUSE]
    - This  is intended behavior in the current GoldMine product range.
    - As the name of an Automated Process should be more descriptive  than the process code, plus it should be avoided to use the same Automated Process  names several times within a GoldMine system, we do not expect a high  inconvenience for customers.