When Web Site is set as required field and copy current record is used on a new record creation an Input all required fields message appears although Web Site appears to be filled

Version 1

    Details

    When Web Site is set as required field and copy current record is used on a new record creation an Input all required fields message appears although Web Site appears to be filled

    [STEPS TO PREPARE]

    1. Log in with master rights
    2. Right Click on Web Site >> Properties
    3. Tab Security
    4. Set Web Site as required field via the check box Required Data Entry



    5. OK


    [STEPS TO REPRODUCE]

    1. Browse to any contact where the Web site is filled
    2. Button New Record
    3. Select the check box Copy current record
    4.  Verify that all expected fields are taken over only individual fields  like Contact name and Email address are blank, also verify that the  original Web site is displayed
    >> RESULT: appears as expected



    5. Enter or even leave the Contact name blank
    6. OK
    >>  RESULT: a message appears Input all required fields >> as Web  Site is in this scenario the only required field it means that the  displayed value is not really available for the new contact record


    7. Press OK
    8.  Click into the Web Site field and retype the web site information (you  may either simply overwrite or highlight >> CTRL+C >>  CTRL+V)


    9. Press OK
    >> RESULT: This time the contact record is created and no further message appears to Input all required fields


    Resolution

    [CAUSE]
    This is RM # 231982

    [WORKAROUND]
    1. On the New record window >> Click into the Web Site field
    2. Mark/highlight the complete value
    3. COPY + C
    4. COPY + V
    5. OK
    - Alternatively overwrite the 'displayed' website value