"Object reference not set to an instance of an object" error when logging into the system, deleting a user or changing their password

Version 9

    Verified Product Versions

    LANDESK Service Desk 7.6LANDESK Service Desk 7.7.xLANDESK Service Desk 7.8.xLANDESK Service Desk 2016.xLANDESK Asset Central 2016.x

    Environment:

    Service Desk all versions

     

    Requires Access To:

    Database server

     

    Error message:

    The error "Object reference not set to an instance of an object" appears when the user tries to login to the system:

    You get the same message when you try to set a password for the user from the console:

    This can also occur when you delete the user profile from the console.

     

    Cause:

    This can happen if there is no password record for the user in the database. Every user should have a password record in the table TPS_PASSWORD even if this password is blank.

     

    Solution:

    Run the script attached on your database to create a blank password automatically for all the users affected by this issue.