GoldMine Mobile (GMME) - Cannot drill down on Primary Contacts in GoldMine Mobile when the primary view is highly customized

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    Details

    GoldMine Mobile (GMME) - Cannot drill down on Primary Contacts in GoldMine Mobile when the primary view is highly customized


    [STEPS TO PREPARE]

    - Global Support recommend using a demo database.
    1. Log in with a master user
    2. Tools > Configure > Record Types
    3. Expand Primary Field Views
    4. Right Click on Car > Clone
    5. Name = Truck
    6. Enter (a new Primary View Truck will appear in the list)
    7. Highlight the view Truck
    8. In the right upper pane > Click  on the column DB Name (this will sort the list alphabetically)
    9. Highlight each of the following rows > Right click > Delete > Confirm the deletion
    ADDRESS1
    ADDRESS2
    COUNTRY
    KEY2
    KEY3
    KEY4
    KEY5
    In the end only the following fields should be available



    11. Expand the Record Types
    12. Right Click on Other > Clone
    13.  Record Type Name = Truck, in Primary Field View select Truck from the  drop down list, activate Set as Default Record Type, everything else can  be left as default
    14. OK
    15. In the Record Types Administration Center's Toolbar > Apply changes icon (last icon in the row)



    16. Reset IIS

     

    [STEPS TO REPRODUCE]

    1. Create a new record in GMPE of type Truck
    2. Contact/VIN# = Test Truck, Record Type (Key1) = Truck
    3. OK
    4. Start GoldMine Mobile (GMME) regardless if
    a. with Google Chrome or Safari browser
    b. with master rights or without
    5. Contacts Tab
    6. All Contacts
    7.Search or Browse to Test Truck
    8. Try to drill down into Test Truck record

    [RESULT]

    The Test Truck record will not be opened at all it appears as if nothing  happened and the contact data will never be displayed




    [ADDITIONAL NOTES]
    - While there appear even with extended logging (Level set to ALL in GoldMine Connect's Web.Config file nothing at all in the log file, the Developer Tools in Google Chrome show the following error, when drilling down into the contact record
    Cannot read property 'single' of undefined


     


    Resolution

    [CAUSE]
    - This is RM # 233393
    - GMME requires a minimum amount of CONTACT1 fields (also not all of CONTACT1 fields are counting) on the primary  views in order to display a contact record.
    - While also other CONTACT1 fields made it possible to drill down again into the current contact record in GMME, The  current recommended workaround/resolution is to put one or several EXTx fields back onto the  screens/views


    [WORKAROUND]
    1. Make sure to have a full running backup of the GoldMine database
    2.  Although technically not necessary it would be recommended that this is  done while no one is logged into GoldMine Premium Edition
    3. Log in with Master rights
    4.  On a contact record in the top part
    a. Right Click > New Field (this opens the screen designer and at the bottom right the Place Field window)
    b. Open the drop down and scroll down to the EXT1 field
    c. OK
    d. The field Ext1 appears usually in the middle of the screen (might be in the Fields tab)
    e. Drag the Ext1 field to the primary view
    f.  Double click on it, this will open the Field Properties dialog  (if applicable make some changes, for example to rename the label etc)
    g. OK
    h. If applicable repeat the same steps for the remaining EXT fields
    5. If applicable this needs to be verified and also adjusted on further Primary views via Right Click in the top part of the Contact record (Primary View)  > Select Primary Fields > Select the next Primary view in  the list



    6. Exit the Designer
    7. Restart IIS
    8. Verify the behavior in GoldMine Mobile.



    [ADDITIONAL NOTE]
    -  While it might be necessary to add further CONTACT1 fields on the primary views there are  possibilities to hide them from the screen for example via Hiding fields  and values, Please refer to the Online help for further  information via Help > GoldMine Help > Administration  Guide > Customizing GoldMine > Customizing Field Typing >  Hiding Field Labels and Values
    - Please review also the following related Knowledge Articles as screen customization may have impact on GoldMine Mobile
    17572 - GoldMine Mobile (GMME) - Cannot drill down on Primary Contacts in GoldMine Mobile once the contact record has any phone number.
    17575 - GoldMine Mobile (GMME) - When the Lastname field is removed from the Primary field view(s), My Contacts in GMME remains blank.