GoldMine Web (GMWEB) - No right click / context menu does not appear in Internet Explorer while it appears in Google Chrome

Version 1

    Details

    GoldMine Web (GMWEB) - No right click / context menu does not appear in Internet Explorer while it appears in Google Chrome

    [SCENARIO]
    1. Start Internet Explorer
    2. Start GoldMine Web as usual via the provided URL http://servername/goldmine/web
    3. Right Click on the Web site in order to verify the used GoldMine Connect version or (since GoldMine Connect 2015.1.0. and higher) the used Contact and GoldDir
    >> RESULT:
    Nothing happens when right click, the context menu does not open at all

    4. Start Google Chrome
    5. Start GoldMine Web as usual via the provided URL http://servername/goldmine/web
    6.  Right Click on the Web site >> View Page Source - in order to verify the used GoldMine  Connect version or (since GoldMine Connect 2015.1.0.380 and higher) the  used Contact Files and GoldMine Files
    RESULT:
    The context menu appears when right clicking on the GoldMine Web website







    Resolution

    [CAUSE]
    The Internet Explorer settings are restricted by a Windows policy set by the System Administrator. The responsible setting is "Turn off Shortcut Menu" in the User Configuration >  Administrative Templates > Windows Components > Internet Explorer  > Browser Menus

    [STEPS TO RESOLVE]
    - This needs to be performed by the Windows System Administrator or a Windows User with appropriate rights
    -  Further information which is provided by GoldMine Technical Support  only as-is and without any warranty of any kind can be found on the  below threads. Please keep in mind that any non GoldMine or non Heat  Software links are only provided as-is and content and availability may  change at any time without any notice
    - Steps may vary for Operating  Systems and / or Domain Environments (the following steps are taken from  Windows 2012 R2 Server in a Workgroup Environment)

    1. Log in as Administrator (or a Windows User with Administrator's rights)
    2. Start >> gpedit.msc
    3. Browse to User Configuration > Administrative Templates > Windows Components > Internet Explorer > Browser Menus
    4. On the right pane >> Browse to Turn off Shortcut Menu (this should be set currently to Enabled)


    5. Double click on Turn off Shortcut Menu or use the Hyperlink Edit policy setting
    6. Either set it to Not Configured (Default Windows Setting) or set it explicitly to Disabled


    7. Apply >> OK
    8. Restart Internet Explorer and the GoldMine Web website
    9. Right Click in order to open the context menu >> View Source





    Additional Note:
    - This Windows policy restriction has also impact on various areas within GoldMine Premium Edition for example
    a. Cannot right click Notes and bring up the context menu. (Knowledge Article # 18765)
    b. Cannot right click in GM+View and bring up the context menu. (Knowledge Article # 18766)
    c. Cannot right click in the Email Read window and bring up the context menu. (Knowledge Article # 18771)