GoldMine Web (GMWEB) - no error message, but when opening a certain contact record in GoldMine Web there appears only a message The contact record couldn't be opened. Please inform your GoldMine Administrator. (Opening this record in GoldMine Premium Edi

Version 1

    Details

    GoldMine Web (GMWEB) - no error message, but when opening a certain contact record in GoldMine Web there appears only a message  'The contact record couldn't be opened. Please inform your GoldMine Administrator. (Opening this record in GoldMine Premium Edition may resolve the issue.)'

    [STEPS TO REPRODUCE]
    1. Log into GoldMine Web
    2. On the CONTACTS list try to open a contact record (here Bea Defkow)


    >> RESULT
    - There appears no error message on top of the screen like Failed to get contact list or similar as a pop-up window at all on screen but the record is not opened and instead GoldMine Web shows 'The contact record couldn't be opened. Please inform  your GoldMine Administrator. (Opening this record in GoldMine Premium  Edition may resolve the issue.)'



    - Neither the GMConnect.log file nor the GMWeb.log file show any error

    3. Log into GoldMine Premium Edition
    4. Browse to / Search for the identical contact record


    5. Open the contact record
    >> RESULT:
    It seems nothing at all happened


    6. Repeat steps 1 and 2 again for the same contact record
    >> RESULT:
    This time the contact record opens as expected also in GoldMine Web



    Resolution

    [CAUSE]
    - The  underlying CONTACT1 record  for the specific contact record does not have a related CONTACT2 record.  Both tables have a 1:1 relationship
    - The reason why there is no  related CONTACT2 record for the specific ACCOUNTNO may vary and can be a  data corruption, a wrong import or due to other reasons
    - While  Goldmine Premium Edition can handle this situation and creates a  CONTACT2 record on the fly if necessary, GoldMine Web cannot do this.
    -  GoldMine Web opens by default also user defined fields in the contact  view which is the reason why this message appears as there is no related  record (from CONTACT2) with the user defined fields

    [STEPS TO VERIFY]

    - The following query may help GoldMine Administrator to identify affected contact records
    1. Tools >> SQL Query
    2. Copy and paste the following query into the pane

    select * from Contact1 whereaccountno not in (select accountno fromcontact2)


    3. Button Query



    [STEPS TO RESOLVE]
    -in GoldMine Premium Edition
    1. Log in with master rights
    2. Run the above verification query
    a. Tools >> SQL Query
    b. Copy and paste the following query into the pane

    select * from Contact1 whereaccountno not in (select accountno fromcontact2)


    c. Button Query


    3. Tab Groups
    4. Button New Group
    5. Provide an appropriate name and make sure to have Build the Group activated


    6. Select SQL Query records
    7. Go further through the Wizard with no changes >> Finish


    8. Tools >> Data Management >> Global Replace
    9. Exchange the values of two fields


    10. Set in both fields LinkedIn (Ulinkedin)


    11. Make sure that Expand partial contact records is activated


    12. Select the group created in steps 3. - 7.

    13. Finish
    14. Execute the original query from step 2. again as now the result should be 0
    15. Verify the behavior again in GoldMine Web >> there should be no such behavior anymore due to missing CONTACT2 records