GoldMine Web (GMWEB) - Opening Opportunities in GoldMine Web results in error: Server Error: An error has occurred on the server. Please contact your system administrator. - when using labels for Opportunity and Project Management

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    Details

    GoldMine Web (GMWEB) - Opening Opportunities in GoldMine Web results in error: Server Error: An error has occurred on the server. Please contact your system administrator. - when using labels for Opportunity and Project Management


    [PRE-REQUISITES]

    - GMConnect installed and functional
    - Have several opportunities

    [STEPS TO PREPARE]

    1. Log into GMPE with master rights
    2. Go To >> Opportunities
    3. Button Customize
    4. In tab Labels >> change the label for Manager to Reg.Mgr.
    5. OK





    [STEPS TO REPRODUCE]
    1. Restart IIS
    2. Log into GoldMine Web
    3. Open the OPPORTUNITY page
    >> RESULT:
    - The page opens without any errors and the list of opportunities is available
    - The Header bar shows Manager although it should display as Reg. Mgr.
    - And you can also drill down into on opportunity and see the changed label as Reg. Mgr.





    4. Log into GMPE with master rights
    6. Go To >> Projects
    7. Button Customize
    8. In tab Labels >> change the label for Manager to Reg.Mgr.
    9. OK



    10. Restart IIS
    11. Log into GoldMine Web
    12. Open the OPPORTUNITY page
    >> RESULT:
    Server  Error: An error has occurred on the server. Please contact your system  administrator.the related GMConnect and GMWEB log files do not log the  error




    Resolution

    [CAUSE]
    - This behavior as described above relates the fact that Custom labels in Opportunity / Project Management are used >> This was logged as RM issue 230676 - GMWEB - when using labels for Opportunity and Project Management, opening GoldMine Web Opportunities results in error: Server Error: An error has occurred on the server. Please contact your system administrator.

    - This affects GoldMine Connect versions 2015.1.0.351 (GA-release), 2015.1.0.367 (Hot fix 1) and 2015.1.0.375 (Hot fix 2) - verify via right click on the GoldMine Web page >> View Page Source - see related Knowledge Article # 15650 -  GoldMine Web (GMWEB) - Where and how to find the used version of GoldMine Web within a GoldMine Web (GMWEB) session?)

    Important information:
    - Please make sure to review also the related Knowledge Articles
    a. # 18540 :  GoldMine Web (GMWEB) - Opening Opportunities in GoldMine Web  results in error: Server Error: An error has occurred on the server.  Please contact your system administrator. - When adding a user defined  field in Opportunity Manager containing any parts of the field name as  existing default field names
    b. # 18541 - GoldMine Web (GMWEB) - Opening Opportunities in GoldMine Web results in error: Server Error: An error has occurred on the server. Please contact your system administrator. - with no customization at all or not known offending customization for Opportunities and Projects as this or also the other articles may need to be considered to resolve the experienced behavior


    [RESOLUTION]
    - Upgrade GoldMine Connect to version 2015.1.0.380 (Hot fix 3 or higher)
    - In order to address this specific behavior it is only necessary to upgrade GoldMine Connect and not necessarily also GoldMine Premium Edition - see related Knowledge Article # 17021 -  Generic questions about Hot fixes and any new versions of  GoldMine Premium Edition (GMPE and GMConnect) - is it necessary to apply  every month?  Is it necessary to upgrade always both applications? Is  it necessary to uninstall and reinstall both applications?