How to migrate an undocked install to a new laptop

Version 1

    Details

    How to migrate an undocked install to a new laptop


    Resolution

     

    [STEPS]

    1. Log into MSSQL on the undocked machine
    2. Make a backup (.bak) of each database that needs to be moved to the new undocked machine
    3. Move the .bak files to the new undocked machine by the method of your choice
    4. Install SQL Server on the new server.  Be sure to install SQL as “Mixed Mode” authentication (see attached Install guide if you need steps to install SQL)
    5. Create a new blank database shell for each database that will be restored into SQL on the new undocked machine [set compatibility level if you are using a newer version of SQL on the new server: SQL 2008 is Level 90]
    6. Restore the .bak file to each database shell that was created respectfully
    7. Install GoldMine (the same version) on the new undocked machine and select “Create new database”.  This is just a dummy database to connect to GoldMine
    8. Login using the default username and password combo: master/access
    9. Once connected to the new database in GoldMine you may add in the additional databases by clicking on Tools > Databases > Alias Manager.  



    10. Once the alias is created for each database click Tools > Databases  > Open Database and attach each alias using the Attach button





    11. To open the database click on Tools > Databases > Open Database
    12. Highlight the database and click OPEN

    **While logged in as a Master/access   you should also set the login database under  Tools > Options > Login. Set the database under GoldMine Database and Default Contact Database. File > Exit from GoldMine and log back in to open the Restored database.

    13. On the production (old) server copy the GoldMine root directory and move it to a different directory the new server.  (desktop is fine)
    14. Move the desired data files into the new GoldMine directory. (default is C:\Program Data)
    a. FOLDERS: Please note that some of these folders might not exist if you do not use the specific feature associated with the folder.
      \Docs
      \Reports
      \Templates
      \Mailbox  
      \TMPLinks
      Macros
      \Sync
      \Setup
      \Speller
    b. FILES:  Please note that some of these files might not exist if you do not use the specific feature associated with the file.  All located at the root of GoldMine Folder. Be sure to include the Master files as well. 
      username.ini - Example, your user name is Steve, the file will be Steve.ini.
      username.tbi - Example, your user name is Steve, the file will be Steve.tbi.
      username.bin – Example, your user name is Steve, the file will be Steve.bin. 
      Lookup.ini

    [ADDITIONAL INFORMATION]
    Depending on the file path of the linked documents/attachments, you may need to update the database references on the back end to reflect where the new files are located by using the Linked Document Mover under Tools > Data Management > Move Linked Docs & Attachments