ERROR: An error has occurred on the server. Please contact your system administrator. - when drilling down on primary contact records but not on additional contacts within GoldMine Mobile Edition (GMME)

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    Details

    ERROR: An error has occurred on the server. Please contact your system administrator. - when drilling down on primary contact records but not on additional contacts within GoldMine Mobile Edition (GMME)

    [PRE-REQUISITES]
    Configured and properly running GoldMine Mobile (GMME)

    [STEPS TO REPRODUCE]

    1. Start GMME
    2. Contacts
    3. All Contacts
    4. + (add a contact) button
    >> Result: ERROR as shown below
    5. In GoldMine created a new contact record
    6. In GMME
    7. Contacts
    8. All Contacts
    9. New contact from 5. is available
    10. Drill down on contact
    >>Result: ERROR as shown below





    Resolution

    [CAUSE]
    - An identified reason but not exclusively root cause, is that the CONTUDEF table for the current used contact set database contains duplicate entries for a Field_Name (the name for a field in the Microsoft SQL Server back end).
    - This might be related to a CONTACT1 and/or a CONTACT2 field, so the whole table needs to be verified
    - Via the following SQL query it can be already verified if the CONTUDEF contains any duplicate rows (can be used also within GoldMine >> Tools >> SQL Query

    SELECT  COUNT(*), FIELD_NAME, DBFNAME FROM CONTUDEF GROUP BY FIELD_NAME, DBFNAME ORDER BY COUNT(*) DESC
     



    IMPORTANT INFORMATION:
    - The following steps should only be performed by an experienced GoldMine and SQL Administrator as deleting  wrong data in the back end will result in data loss and malfunction of  GoldMine!
    - The FIELD_NAME ACCOUNTNO is 2 times available in the CONTUDEF table one time with a DBFNAME CONTACT1 and one time with a DBFNAME CONTACT2 >> This is NO DUPLICATE 

    [RESOLUTION]
    - Although it is technically not absolutely necessary, it is highly recommended that all users are logged out of GoldMine and GMME, also all users should close any applications integrating with GoldMine, and services accessing the GoldMine application should be stopped by an Administrator

    1. Make sure to have a full running backup of the GoldMine database you will change
    2. In SQL Server Management Studio >> browse to and expand the GoldMine/Contact Set database
    3. Expand Tables and right click on CONTUDEF >> Edit Top 200 Rows (if there are more than 200 records in this table this needs to be adjusted by increasing the Top 200 value via the show SQL Pane button)
    4. Verify and delete duplicate rows (make sure that both entries are identical and if not verify which entry is the proper one used within GoldMine)
    5. Start GMME again and verify the behavior again





    Additional information:
    - It is highly recommended to document the change in the back end
    - Keep in mind that this change is not sync aware, which means, if you recognized duplicates in the CONTUDEF table this should be checked also on any remote GoldMine systems

    - When any fields with a DBFNAME  CONTACT2 were deleted it is strongly recommended to perform a maintain  individual tables (CONTUDEF + CONTACT2) with rebuild and pack the  database tables from within GoldMine (Tools >> Databases >>  Maintain Database feature).  For the deletion of the back end, it is  strongly recommended that all users are logged out, all applications  integrating with GoldMine are closed and all services accessing the  GoldMine database or application, this is absolutely necessary when  performing a rebuild and pack action, After the rebuild action the user  defined fields where a duplicate was deleted from CONTUDEF need to be  verified. Also in this case it is necessary to restart the IIS again  before users log again into GoldMine Web or GoldMine Mobile