For some users the Document Management Center expands by default the tree, while for other users the template tree is always collapsed

Version 1

    Details

    For some users the Document Management Center expands by default the tree, while for other users the template tree is always collapsed

    Is there any setting which can change the behavior for a user?


    Resolution

    - There is no setting available in the GoldMine user interface but this can be adjusted in the USER.INI via the ExpRoots setting in the section [DocCtr].
    - The ExpRoots setting contains 8 entries separated with a ; where each value can be 1 or 0 whereby the following list is a selection of possible combinations (further variations of the below are possible)

    ExpRoots=0;0;0;0;0;0;0;0; collapsed: All Entries
    ExpRoots=1;0;0;0;0;0;0;0; expanded: Document Templates root
    ExpRoots=1;1;0;0;0;0;0;0; expanded: Document Templates root + E-mail Templates root + E-mail Templates >> Defaults
    ExpRoots=1;1;1;0;0;0;0;0; expanded: Document Templates root + Document Templates >> Defaults  + E-mail Templates root + E-mail Templates >> Defaults
    ExpRoots=1;1;1;1;0;0;0;0; expanded: Document Templates root + Document Templates >> Defaults  + Document Templates >> Letters, Memos and Faxes + E-mail Templates root + E-mail Templates >> Defaults
    ExpRoots=1;1;1;1;1;0;0;0; no change from before (minor glitch within GoldMine >> was intended to additionally expand Document Templates >> Spreadsheets)
    ExpRoots=1;1;1;1;1;1;0;0; expanded: Document Templates root + Document Templates >> Defaults  + Document Templates >> Letters, Memos and Faxes + Document Templates >> Envelopes + E-mail Templates root + E-mail Templates >> Defaults
    ExpRoots=1;1;1;1;1;1;1;0; expanded: Document Templates root + Document Templates >> Defaults  + Document Templates >> Letters, Memos and Faxes + Document Templates >> Envelopes + Document Templates >> Labels + E-mail Templates root + E-mail Templates >> Defaults
    ExpRoots=1;1;1;1;1;1;1;1; expanded: All entries

    [STEPS]
    1. Log out of GoldMine as the user e.g. JOHN (in the following example)
    2. Browse to the GoldMine shared folder
    3. Make a copy of JOHN.INI and rename it to JOHN.INI.BAK (so that you still have the backup file for the original USER.INI)
    4. Open the JOHN.INI with Notepad
    5. Add/adjust the ExpRoots entry in the section [DocCtr] e.g. as desired

    >> the entry may look then like

    [DocCtr]
    ExpRoots=1;1;1;1;0;0;0;0;


    6. Save the file JOHN.INI
    7. Start GoldMine as JOHN again
    8. Verify the behavior now by Go To >> Document Templates
    9. After verifying that everything works now as expected the backup file JOHN.INI.BAK can be deleted




    Additional Information:
    - this applies only to the GoldMine default entries and not to further sub-folders e.g. Sample Blank Templates
    - a GoldMine Administrator can force the which folders in the Document Management Center are expanded by an user-override setting for the section in the GM.INI. The GM.INI contains already a [DocCtr] entry, this must not be changed and the override must be set separately. This should be documented and communicated with the users as it will override their personal preferences e.g.
    [User-Override:DocCtr]
    ExpRoots=1;1;1;1;1;1;1;1;
    -