Error: Setup was unable to parse the database platform GoldMine is trying to upgrade. The Installation cannot be upgraded.

Version 1

    Details

    This problem occurs when starting the GoldMine installer on the GoldMine application server 

    [RESULT]
    Instead of starting the Install wizard and getting to the Welcome to the GoldMine Installation Wizard, an error message appears:
    'Setup was unable to parse the database platform GoldMine is trying to upgrade. The Installation cannot be upgraded.'


     

    [CAUSE]
    the DBALIAS.INI is corrupt or contains wrong entries


    Resolution

    The options to resolve this problem are:

    A. if possible verify from the GoldMine user interface
    1.Start GoldMine with master rights
    2. Tools >> Databases >> Alias Manager
    3. via Edit Alias verify each database alias for having proper entries; via the button Test Connection verify the connection
    - if applicable delete duplicates
    - if applicable delete unused entries
    4. OK >> OK
    5. Close GoldMine
    6. Try to upgrade again


    B. For GoldMine Administrators knowing the layout of the DBALIAS.INI or when resolution A, did not lead to success,
    (see also Knowledge Article # 13314 :  What is the purpose of the DBALIAS.INI file and what is the content of the file?)
    1. Browse to the GoldMine shared folder
    2. Browse to the DBALIAS.INI (it is recommended to make a backup of the file)
    3. Open the DBALIAS.INI and verify the correctness of all ALIAS entries
    - if applicable delete duplicates
    - if applicable delete unused entries
    - make sure that there is a [ALIAS1] section with proper entries
    4. Save the corrected DBALIAS.INI
    5. Try to upgrade again