Fields show 'n/a' after changing the "name in database" for these fields

Version 1

    Details

    Fields show 'n/a' after changing the "name in database" for these fields


    Resolution

    IMPORTANT NOTE: NEVER change the "Name in the database" for any fields that have already been built into the database tables. The Name in the database is what is built into the tables. You may change the local and global labels of the fields but not the "Name in the database"

    In the below example KEY4 has been changed to INSURANCE and now shows "n/a" next to the Field



    1. Right-click on the database fields and select "Properties".
    2. Click "More Options"
    3. In the "Name in Database" change this back to the original field name (in our example this will be KEY4

    From



    To



    4. Click OK > OK to confirm the change and set the field back to its correct value.



    We would also advise to run database maintenance but this is not necessary unless you have created new Userdefined fields in the Contact2 table.

    - Have all users log out of GoldMine
    - Verify that you have good current backups of all databases
    - Log into GoldMine as a master user
    - Go to Tools > Databases > Maintain database (or in old style menu this would be File > Maintain database)
    - Click OK to the warning
    - Select "All database files", Next > Next > Next > Finish
    - Go back to Tools > Databases > Maintain database (or in old style menu this would be File > Maintain database)
    - Select "All database files", Next > Select "Rebuild and Pack, Sort and Verify", Next  > Finish
    - Verify that the field shows the correct data or the field can be edited and that the words "n\a" do not show against the field.