Prev Result field on the Summary tab will not update when the Reference on a completed history item is changed.

Version 1

    Details

    Prev Result field on the Summary tab will not update when the Reference on a completed history item is changed.

    [STEPS TO REPRODUCE]

    1. Browse to Art Bardtoll
    2. Browse/Open the Summary tab
    3. Verify the current content of the Prev Result field



    4. Complete > Unscheduled > Incoming Call
    5. Type into the Reference "Requested Lit."



    6. Leave all other fields as they are >> OK
    7. Verify the current content of the Prev Result field again

    [RESULT]

    The Prev Result field displays now Requested Lit.



    8. Browse / Open the History Tab
    9. Right Click on the completed activity from steps 4.-6. > Edit
    10. Change the Reference from "Requested Lit." to "Requested Literature about GoldMine"



    11. OK
    12. Browse/Open the Summary tab
    13. Verify the current content of the Prev Result field again

    [RESULT]
    The Prev Result field still displays Requested Lit. and not as expected the changed Reference from step 10.



    Additional Note:
    - performing the same steps on the next scheduled activity (Pending tab) will reflect the change in the Reference for the Next Step field on the Summary tab








     


    Resolution

    [CAUSE]
    - This is RM # 231125
    - Currently there is no workaround available other than to update the field manually, whereby this approach is most likely not very useful as at once another activity will be completed for the contact record the Prev Result field will be overwritten anyway