GoldMine Web (GMWEB) - Switching to CONTACTS page getting error: "Server Error - Get Local Exclude string error"

Version 2

    Details

    GoldMine Web (GMWEB) - Switching to CONTACTS page getting error: "Server Error - Get Local Exclude string error"

    [STEPS TO REPRODUCE]

    1. Open the GMWEB link in an supported browser
    2. Log into GoldMine Web

     

    [RESULT:]
    - When switching to the CONTACTS page or prior GoldMine Web 2017.1 by default the CONTACTS page appeared within GoldMine Web the user receives immediately the error "Server Error - Get Local Exclude string error"
    - The error repeats over and over again when pressing OK and the user needs to click the X in order to get out of this loop
    - Any further action on the CONTACTS section within GoldMine Web will cause the error to constantly reappear

     


     

     


    Resolution

     

    [CAUSE]

    - GoldMine Web (same as GoldMine Mobile) needs to verify if any screens need to 'excluded'. This information is stored in the CONTSUPP table's system record (ACCOUNTNO = 90CF-SYSTEM-REC) in the field NOTES (for example: {ExcludeViews:.v100002})
    - Therefore Within 1 GoldMine Contact Set only 1 system record should be available and GoldMine Web requires that only 1 row is within the Contact Set and the error occurs when there are more than 1 system records available.
    - It cannot be determined why a GoldMine system may have more than 1 system record, but this needs to be cleaned up by a GoldMine Administrator or the Microsoft SQL DBA

     


    [STEPS TO RESOLVE]

     

     

    -  Make sure to have a full running backup of the GoldMine database


    1. Stop IIS on the GoldMine Web server
    2. Open SQL Management Studio

    3. Via the New Query button > Run the following query against the GoldMine database or specific Contact Set database:

     

    SELECT * FROM CONTSUPP WHERE ACCOUNTNO = '90CF-SYSTEM-REC' ORDER BY RECID DESC

     

     

    4. Keep the oldest entry (with the lowest RECID) and delete any duplicates
    5. Start IIS again on the GoldMine Web server

    6. Verify the behavior again in the GoldMine Web Client.

     

     

     

    Note: It is recommended to verify also all remote  sites or undocked machines if there are duplicate “90CF-SYSTEM-REC” records