Error installing Universal search - Description: Column 'XYZ' cannot be used for full-text search because it is not a character-based, image, or varbinary(max) type column.

Version 1

    Details

    Error installing Universal search  - Column 'XYZ' cannot be used for full-text search because it is not a character-based, image, or varbinary(max) type column.
    Example Error below

    GM version: 2016.1.0.188 R Thread ID 4284:

    ADO Error in CApplicationData::Execute code - CREATE FULLTEXT INDEX ON dbo.CONTACT2
    (
     [LASTCONTAT] LANGUAGE 0x0,
     [COMMENTS] LANGUAGE 0x0,
     [PREVRESULT] LANGUAGE 0x0,
     [NEXTACTION] LANGUAGE 0x0 ,
     [UFACEBOOK] LANGUAGE 0x0,
     [ULINKEDIN] LANGUAGE 0x0,
     [USERDEF01] LANGUAGE 0x0,
     [USERDEF02] LANGUAGE 0x0,
     [USERDEF03] LANGUAGE 0x0,
     [USERDEF04] LANGUAGE 0x0,
     [USERDEF05] LANGUAGE 0x0,
     [USERDEF06] LANGUAGE 0x0,
     [USERDEF07] LANGUAGE 0x0,
     [USERDEF08] LANGUAGE 0x0,
     [USERDEF09] LANGUAGE 0x0,
     [USERDEF10] LANGUAGE 0x0,
     [USERDEF11] LANGUAGE 0x0,
     [USERDEF12] LANGUAGE 0x0,
     [USERDEF13] LANGUAGE 0x0,
     [USERDEF14] LANGUAGE 0x0,
     [USERDEF15] LANGUAGE 0x0,
     [USERDEF16] LANGUAGE 0x0,
     [UTWITTER] LANGUAGE 0x0)
         KEY INDEX CN2RECID
         ON ftscat_ContactSetFiles
         WITH CHANGE_TRACKING AUTO
    Com Error IDispatch error #3092
        HRESULT    : -2147217900
        Description: Column 'USERDEF15' cannot be used for full-text search because it is not a character-based, XML, image or varbinary(max) type column.
     



    Resolution

    [CAUSE]
    This error suggests that the field in thew error is set as a Numeric in SQL (Contact2 table)
    But most likely a Character in GoldMine.

    [RESOLUTION]
    To rectify this do the following
    1. Open the Contact2 tables in SQL management studio and review the Field userdefined15 (In this example we have set it to an INT to replicate the issue)



    2. Open GoldMine
    3. Tools > Configure > Custom Fields
    4. Review the field Userdefined15 here



    Here you can see the field is a character field.

    5. Modify the field in GoldMine (Click Properties)
    6. For example set it to a numeric to match what it is set to in SQL



    7. Click OK

    8. Click Close
    9. Click NO to the database rebuild dialog, then OK to the warning



    10. You can now try and install universal search again
    11. Tools > Configure > System Settings
    12. Advanced tab
    13 Click Uninstall to remove Universal Search (Click Yes to uninstall it)
    14. Tools > Configure > System Settings
    15. Advanced tab
    16. Click Install to reinstall Universal Search (Click yes to install, Hopefully this time with no error messages)