Network Settings for the Managment Gateway will not save changes.

Version 5


    After installing the GSBopenssl0.9.8i patch, the Networks Settings will no longer be saved any changes made from the local or remote web interface.


    Saving changes to the Network settings, fails and reverts the properties of the Network Settings back to what it was before making the changes.  This happens wen connected remotely through the web or when logged into the local interface.


    The ifconfig.eth0 and ifconfig.eth1 directories in the /etc/sysconfig/network-devices/ location are set with the incorrect Permissions and Group ownership.


    Affected Directories:




    Incorrect Permissions:

    Permissions: 755

    Owner: root

    Group: root


    Correct Permissions:

    Permissions: 775

    Owner: root

    Group: webedit


    1. Log into the Management Gateway.

      Note: to make these changes you need to be logged in locally.  The necessary changes cannot be made from a Web based console.

    2. Press Alt-F2 to switch to a different screen.

      Note: To switch back to the main screen press Alt-F1.  The windows manager that the Gateway uses is Fluxbox.

    3. Right-click anywhere on the desktop to get the Fluxbox menu to appear.  It will display some options as follows:

      • xterm
      • Admin Console
      • fluxbox menu
        • Logout
        • Reboot
        • Shutdown
    4. Choose xterm.  This opens an xterm command prompt.
    5. Change directories to /etc/sysconfig/newtork-devices
    cd /etc/sysconfig/newtork-devices
    1. Fix the permissions and group ownership of the ifconfig folders with these commands:
    sudo chmod 775 ifconfig.*
    sudo chgrp webedit ifconfig.*

    After these modifications have been made you can now modify or delete settings in the Management Gateway's Network settings.