Migrating GoldMine to a new server.[Uploaded File]

Version 2

    Details

    How to move any version of GoldMine and SQL to a new server.


    Resolution

    If you have any questions about the below steps you may contact your GoldMine solutions partner for further assistance.  Please note these steps do not take into account all variations in a migration path to a new server.

    1. Log into MSSQL on the production server.
    2. Make a backup (.bak) of each database that needs to be moved to the new server within SQL Management Studio
    3. (see youtube for directions: https://www.youtube.com/watch?v=eK526X3UhMM)
      Make a backup of the GoldMine directory of the server
    4. Move the GoldMine directory and the .bak file/s to the new server by the method of your choice (desktop if fine)
    5. Install SQL on the new server.  Be sure to install SQL as “Mixed Mode” authentication (see attached Install guide if you need steps to install SQL)
    6. Create a new blank database shell for each database that will be restored into SQL on the new server [set compatibility level if you are using a newer version of SQL on the new server: SQL 2008 is Level 100https://docs.microsoft.com/en-us/sql/t-sql/statements/alter-database-transact-sql-compatibility-level
    7. Restore the .bak file to each database shell that was created respectfully (Verify in the Options of the SQL Database that the option "Overwrite the existing database (WITH REPLACE) is selected)
    8. Install GoldMine (the same version) on the new server and select “Create new database”. This is just a dummy database to connect to GoldMine – name it TEST
    9. Login using the default username and password combo: master/access
    10. Once connected to the new database in GoldMine you may add in the additional databases by clicking on Tools >> Databases >> Alias Manager.

     

     

    11. Once the alias is created for each database click Tools >> Databases  >> Open Database and attach each alias using the Attach button

     

     

    12. To open the database click on Tools > Databases >> Open Database

    When opening this database, it will warn you that it is out of date and you must upgrade, please choose YES to upgrade the back end of the database.

     

    13. Highlight the database and click OPEN

    **While logged in as a Master/access   you should also set the login database under  Tools > Options >> Login. Set the database under GoldMine Database and Default Contact Database. File > Exit from GoldMine and log back in to open the Restored database.

     

     

    14. On the production (old) server copy the GoldMine root directory and move it to a different directory the new server.  (desktop is fine)

    15. Move the directory files into the new GoldMine directory. (default is C:\Program Data)

              a.  FOLDERS: Please note that some of these folders might not exist if you do not use the specific feature associated with the folder.

                i.        \Docs   

                 ii.       \Reports

                 iii.      \Templates

                  iv.      \Mailbox

                  v.       \TMPLinks

                 vi.      \Macros

                  vii.      \Sync

                  viii.     \Setup

                  ix.       \Speller

     

         b. FILES:  Please note that some of these files might not exist if you do not use the specific feature associated with the file. 

                             All located at the root of GoldMine Folder. Be sure to include the Master files as well.

                  

              i.      username.ini - Example, your user name is Steve, the file will be Steve.ini.

            ii.     username.tbi - Example, your user name is Steve, the file will be Steve.tbi.

             iii.    username.bin – Example, your user name is Steve, the file will be Steve.bin.

              iv.      Lookup.ini

     

    16. Add the SYSDIR line with a path to the GoldMine share in the GM.ini on the new server

    17. Update the GM.ini on each client machine to point to the new server directory

         a. If you were launching GoldMine from a network share you may have to re-map the new server and change the target of the GoldMine icon.

         b. Local installs will have their own gm.ini file in the GoldMine root directory.  This gm.ini will need to be updated to reflect the location of the new realini location.

     

    ** please note that depending on the file path of the linked documents/attachments, you may need to update the database references on the back end to reflect where the new files are located by using the Linked Document Mover under Tools > Data Management > Move Linked Docs & Attachments