How to add/link files to a contact record or an opportunity/project?

Version 1

    Details

    How to add/link files to a contact record or an opportunity/project?  - Detailed information about linking files on Links or Details/Links tab.

    Although there is information available for linking files to a contact record's Links tab or to the Details/Links tab of opportunities and projects in the Online Help the following article will provide a more detailed view on this and related topic

    Online Help information related to Linked files on Links and Details/Links tabs available via Help > GoldMine Help
    - User Guide > Contact Management > Linking Files to a Contact Record
    - User Guide > Opportunity and Project Management > Managing Opportunity and Project Details > Editing Details/Links 

    - Administration Guide > Data Maintenance and Management > Moving Linked Documents and Attachments




    Resolution

    [Steps for manually linking a file to a contact record]
    1. Browse to the desired contact record
    2. On the Tabs select Links
    - If Links is not yet visible, Open the arrow drop down on the left side (where the Tabs begin) > select Links
    3. Right Click (on the left pane) > New
    4.a. Provide a Document Name (which represents the name within GoldMine and  can be used for example for building contact groups for example;  Offer xyz)
    4.b. If applicable adjust the Document Owner (by default (public)
    4.c. If applicable enter any Notes
    4.d. At the bottom right via the ... browse to the desired document/file

    (please  keep in mind that you can also link a folder and not single files for example.  \\servername\correspondence\HDA123456
    When launching the link  the folder will be displayed but there is no preview available for such a  link, instead a message appears in preview that the file cannot be  found. Also it must be kept in mind that the files in the folder are not  synchronized
    but only the link record itself)

    4.e. If applicable adjust the file to be allowed to be synchronized or not  (the default setting if the check box is checked or not is set by the  GoldMine Administrator via Tools > Synchronize >  Synchronization Settings > Tab Linked Documents > Option  'Allow new linked files to synchronize by default'). The default setting  can be adjusted per linked file
    5. Click OK







    Alternatively a single  file / or folder can be also dragged simply from the Windows File  explorer into left pane of the Links tab in order to create a record in  the Links tab, when dragging the file into the preview pane instead GoldMine tries to open or preview the file but will not create a Links record.


    versus

    [Steps for manually linking a file to Opportunities or Projects]
    1. Browse to the desired and open the Opportunity or Project
    2. On the Tabs select Details/Links
    - If Details/Links is not yet visible, Open the arrow drop down  on the left side (where the Tabs begin) > select Details/Links
    3. Right Click (on the left pane), Click New
    4.a. Provide an Item information (which represents the type of the detail/link within GoldMine for example Documentation, Contract,

    (Please  keep in mind that specifically Details/Links tab can be used also for  other type of information and not only for linked files, see Online help > User Guide > Opportunity and Project Management >  Managing Opportunity and Project Details > Editing Details/Links)

    4.b. Provide  an Reference information (which represents the name of the detail/link  within GoldMine for example User manual, Admin manual for Documentation  type, and SLA Host, SLA application for Contract type etc.)
    4.c. If applicable adjust that the Document is based on a GoldMine Merge  Form, the dialog lower part of the window changes in order to  select the specific GoldMine template. This can be used for example when  standard catalogs or price lists are in use and setup as GoldMine Merge  Templates.  
    4.d. If applicable adjust the file to be allowed to be synchronized or not  (the default setting applied by the  GoldMine Administrator via Tools > Synchronize >  Synchronization Settings > Tab Linked Documents > Option  'Allow new linked files to synchronize by default' does NOT apply here). The default setting  can be adjusted per linked file.
    4.e. At the bottom right via the ... browse to the desired document/file.

    (Opposite to linked files in a Links tab you can also link a  folder and not single files For Example \\servername\correspondence\HDA123456. Note it will not launch the folder when the details is double clicked, there  is no preview available for such a link, instead a message appears in  preview that the file cannot be found. Also it must be kept in mind that  the files in the folder are not synchronized but only the link record itself)

    5.Click OK




    Alternatively  a single file / or folder can be also  dragged simply from the Windows File explorer into left pane of the  Details/Links tab in order to create a record in the Details/Links tab,  when dragging the file into the preview pane instead GoldMine tries to  open or preview the file  but will not create a Details/Links record.






    Additional information:
    (The  following information is primarily intended for documents/files linked  on Links tabs or Details/Links tab on Opportunities and Projects but  would apply in most cases also to any other area where files can be  linked within GoldMine for example also for knowledge base linked files  etc.)

    I. Possible file types to be linked into GoldMine


    - Any file type can be linked to a contact record, but if a link can be  opened depends if the associated application is installed on the local  machine (for example a Computer Aided Design file might have been added  as link on a contact record by the responsible CAD Team member and can  be opened at the specific machine as there is an associated CAD  application but the same file cannot be opened on the application server  because there is no CAD application installed.

    II. Linked files appearance in the Preview pane

    - If a file will display in the preview pane depends on
    a. If the file type is set by a GoldMine administrator (user with master  rights) to be able to be previewed via Tools > Configure >  System Settings > Tab Preview (further information see Online  help > Administration Guide > User Administration >  Configuring System Settings > File Type Previews).




    b. That an associated application for the file type is installed on the current machine (see I.)
    c. Windows and or Internet Explorer settings, for example PDF files are  opened directly in the application instead of the Preview window see  also Knowledge Article #15736 :  Linked pdf files in Links or on the Details/Links tab of  Opportunity or Projects do open automatically in Adobe Acrobat Reader  when selected instead of showing in preview pane.
    d. There is a known  RM issue # 214124 - Sorry, but Microsoft Office was not installed.This  document cannot be previewed when opening an Microsoft Excel file (xlsx)  document from Links / Details (Opportunity and Projects) tab







    III. Preview of linked files and performance

    - When a record in the Links tab or Details/Links tab is highlighted,  GoldMine's Preview pane will provide a preview of the file depending on  the setting and capability. This means the file needs to be 'opened' or  at least 'read'. This may lead to performance delays when needing to  switch frequently between several links, when network traffic is high,  the files are very large etc. 
    - In order to improve performance it  might be considered to minimize the Preview pane by the >> chevron  at the top of the Preview pane. (This might be also used in regards of  II.c.) If a single link should then be previewed again the Preview pane  can be simply expanded via the << chevron   








    IV. location from where to link files into GoldMine

    - It is absolutely recommended to link files from central and for all  related users accessible shared folders (for example; on File servers), for  example when User A links a file from a location only accessible from  this machine (local folder or a mapped drive only available on this  machine) the link cannot be opened from another machine and a message  appears File NOT found: path and file name.

    V. Moving linked files

    - Please be aware that GoldMine does not store the real file within  the database, but instead only a pointer to the file where the file  (should) reside. If the file is not available on this location, neither  the link record will be removed nor the reference to the file will be  updated automatically.  

    - As it might be necessary to move linked files to a different location  for example after a server migration, or restructuring the file server  and folders or simply with the intention to get originally wrong linked  files (see III. to a proper location) it is necessary to update the database reference of the linked file, otherwise the underlying files  cannot be opened, previewed or synchronized to other systems anymore  from within GoldMine.

    GoldMine Support strongly recommends this to be done .
    a. Either en masse via the Linked Document Mover for example after a server migration  (see Online help >  Administration Guide > Data Maintenance  and Management > Moving Linked Documents and Attachments)




    b. With  the Move feature for a single link via right click on the Link >  Move > select the new location (follow instructions on the  screen)




    c. In rare occasions it might be necessary to use back end  scripts which can be provided by partners, please keep in mind that  those are only provided on exceptional cases by GoldMine Support Team  and are only provided as-is without any warranty.
     

    VI. Synchronizing linked files

    If linked files synchronized or not depends on several factors and all of them must be selected/activated
    - In the specific Site Groups / Sync Site (when Override options are  used), One button Sync profile / Sync Wizard Profile > Send  Records Types > Linked Documents > Links Tab Records  > Linked Documents, also the Retrieve options needs to verified  and adjusted if applicable.

    In the Deletions sections of sync profiles  the Links are included in the Related Contact Info > Additional  Contacts, Details, Referrals, Links and Sales/Marketing Tools >  Oppty/Project Manager




    - On the specific link, the file needs to be allowed for synchronization.

     


    VII. Other ways how records are created on the Links tab

    - This article referred only how manually linking files to a contact record's Links tab is achieved, but also GoldMine can automatically create entries in the Links tab. This can be for example received email attachments or created when documents are merged via the Microsoft Word or Microsoft Excel integration (refer also for example to Online Help > Administration Guide > User Administration > Managing User Options > Setting Options for the E-mail Tab and/or User Guide > Contact Communication > Creating Document Templates with GoldMine Plus Installed).

    - 3rd party applications may create and link files to the Links tab for example Quote Werks.
    Please keep in mind that such applications are not from GoldMine and GoldMine Support may not assist on any inquiries related to such 3rd party applications.

    VII. Database / table information for records in the Links or Details/Links tab :

    -  Linked file references from a Contact record's Links tab are stored in  the Contact Set's CONTSUPP table with a RECTYPE value 'L'
    - Linked file references from an Opportunities or Project's Links/Details tab are stored in the GoldMine Base OPMGRFLD table with a RECTYPE value 'F'