Unable to log into GoldMine, Login failed for user 'sa' because the account is currently locked out.

Version 1

    Details

    Unable to log into goldmine, Login failed for user 'sa' because the account is currently locked out.

    NOTE:
    The username maybe different is you use a different SQL user to connect GoldMine to SQL server


    Resolution

    [CAUSE]
    Either someone has entered the 'sa' password incorrectly more times than the password policy allows or someone has used a brute-force attack to try and log in to the SQL server and locked the 'sa' account

    [RESOLUTION]

    1. Request the IT staff unblock the SQL 'sa' Account
    2. Reset the 'sa' account password in Microsoft SQL Management studio (if the cause was a forgotten password - See Article #19111 :  You do not know the SQL login details and cannot open GoldMine)
    3. Browse to the GoldMine install directory (default is C:\ProgramData\GoldMine\)
    4. Open the DBALIAS.ini file in Notepad.exe
    5. Remove the Text for the PASSWORD= line (see example below)

    [General]
    BDEMigrated=1
    [Alias1]
    Name=GoldMine_Clean_unicode
    ServerType=MSSQL
    HOST=SVR2008R264
    DATABASE=GoldMine_Clean_unicode
    OWNER=dbo
    LOGIN=sa
    PASSWORD="NPY1\#K.1E]!N +T7 I1@6W$><**6 )AM:8 P^E!0#OL$A(!!6C2S#<7^BW$,7;`F$YW@_7 " - Remove this the highlighted text
    USE_SSPI=

    6. Save the file
    7. Launch GoldMine
    - You should then get the following error after you enter your GoldMine username and password



    8. Click <OK> to this error
    - You should then be prompted to enter the SQL login details



    9. Enter the details



    10. Tick the save password box
    11. Click <OK> to save the change and Launch GoldMine.

    [ADDITIONAL NOTE]

    Once you tick the save password box you should not be prompted to enter the SQL login details upon consecutive logins to GoldMine.