A user with master rights can at times not access the Properties for other users within the User's Master File

Version 1

    Details

    A user with master rights can at times not access the Properties for other users within the User's Master File

    [STEPS TO REPRODUCE]
    1. Log in with master rights
    2. Tools > Users' Settings
    3. Right Click to certain users in the users list
    4. Verify if the Properties entry is available or appears as grayed out

    [RESULT:]

    a. At times the user can access the Properties for some users



    b. But not always and it might be the case that for the same user the Properties entry might be grayed out on a new attempt



    c. For some users the user can never access their Properties






    Resolution

    [CAUSE]
    This is usually the case when either
    - an invalid USERNAME (in most cases blank) exists in the USERS table of the GoldMine database and/or
    - a corrupt or invalid 'blank'.INI is available in the GoldMine shared folder on the application server (where the LicenseGMx.bin resides)


    [RESOLUTION]
    A. verification of the USERS table
    1. Log into the SQL Server Management Studio
    2. Browse to the GoldMine Database
    3. Browse to Tables >> USERS
    4. Right Click >> Select Top 1000 Rows (with having exclusive rights to the table a GoldMine Administrator or MS SQL DBA may want to select instead EDIT Top 200 Rows and directly delete rows if applicable)
    5.  add at the end of the statement

    order by username asc

    6. verify that there are no users with blank USERNAMES


     
    B. remove users with blank USERNAME values
    1. Make sure to have a full running backup
    2. All users to be logged out of GoldMine and also closed Office or other integrations with GoldMine
    3. All GoldMine related services be shut down (e.g. GoldSync, IIS etc)
    4. in SQL Service Management Studio
    5. apply the following query on the GoldMine database

    delete from users where username =''



    C. Verify and remove related incorrect or corrupted 'blank'.INI files from the GoldMine share
    1. Browse to the GoldMine shared folder (to identify where this (shared) folder is, from within GoldMine, Help > About GoldMine > Button System > System Files folder - depending on certain setups this may also appear as 'Program data dir')
    2. Log out of GoldMine as the user with master rights
    3. Identify or verify that there are no 'blank' INI files and related 'blank'_info.bin file

    a screenshot would show for example the following (in red marked the corrupted files):



    4. If there are such files make sure that they are removed out of the GoldMine folder
    5. Log in as the user with master rights and verify behavior again
    6. Let other users log in again and if applicable make sure that stopped services and applications are started as usual again