Language Transition Spanish - User's default language on login is not working as expected (UAT & QA)

Version 1

    Details

     

     
    Description   of issue:
       
        Language Transition Spanish - User's default language on login is not   working as expected (UAT & QA).


        Steps to reproduce:
        The below results were received in both QA and UAT.
       
        1. Client user with preferred language as Spanish logs in for first time -   Application is displayed in English
        2. Client user with preferred language as English logs in for first time -   Application is displayed in Spanish
       
        IN UAT: On further investigation, we have noticed that irrespective of   user's preferred language, the language displayed on logging in to the   application is always the last logged-in user's language. For a new user   logging in from a system that has never accessed the application, the language   displayed is English - this is irrespective of the user's preferred   language.
       
        IN QA: On further investigation, we have noticed that irrespective of   user's preferred language, the language displayed on logging in to the   application is always the last logged-in user's language. For a new user   logging in from a system that has never accessed application, we did receive   Spanish (user's preferred language).
       
       

     


    Resolution

    This is working as designed and expected. The Preferred language setting in the employee record has nothing to do with login language. What language the user sees depends on the language selection in the UI and it is remembered in the cookie.