In Universal search you cannot search easily if there is a preposition or special character in the search term

Version 1

    Details

    - In Universal search you cannot search easily if there is a preposition or special character in the search term

    - If you search for something like assessment of need, Upper Limb clinic follow up, meeting with OT, call to parent, you will not receive any results.
    However if you search using % in the blanks then that will work.

    - You may also find that dashes and ampersands in the search. for example CP - will not return results whereas CP%- will. Worries & fears will not return results but Worries%&%fears will.

     

    - Is there an easier way to search in the universal search rather than using % where there is a preposition or a character in the term?


     


    Resolution

    Disable the stop words in SQL

    1. Close GoldMine
    2. Open SQL server Management Studio
    3. Run the below command

    USE GoldMine -- where GoldMine is the name of your SQL database that is hosting the GoldMine database files
    ALTER FULLTEXT INDEX ON CAL SET STOPLIST = OFF


    This  will disable stop words for the CAL table ONLY (for the other indexed  tables you will need to run the same query just replacing the table name
    the other tables that are indexed in the full text search are

    NOTES
    MAILBOX
    INFOMINE
    CASES
    OPMGR
    CONTHIST
    CONTSUPP
    FORMS
    CONTACT1
    CONTACT2

    Log back into GoldMine and test.  This should then force the search to search on the Stop words as well

    This *Should* then work as follows
    If you have 2 activities for example

    - assessment 2
    and
    - 2 days until assessment

    If you search for assessment 2 this should return both activities as the search will look for an activity that contacts both words Assessment and 2
    If you search for "assessment 2" this should search for the phrase assessment 2 and return just the 1 activity

    If stop words are active then as the number 2 is a stop word the search just looks for Assessment in both scenarios

    To enable stop words in SQL again you can run the below query

    1. Close GoldMine
    2. Open SQL server Management Studio
    3. Run the below command

    USE GoldMine -- where GoldMine is the name of your SQL database that is hosting the GoldMine database files
    ALTER FULLTEXT INDEX ON CAL SET STOPLIST = SYSTEM