IDispatch error #31816 Logon failed when running a Cystal Report via GoldMine

Version 1

    Details

    IDispatch error #31816 Logon failed when running a Crystal Report via GoldMine


    Resolution

    [CAUSE]
    The Crystal report itself has different ODBC connection data saved within the report.
    You must set the Crystal Report to use the same ODBC connection that is setup within GoldMine.

    [RESOLUTION]

    1. Open the report in the CR XI designer.
    2. Select Database > Set Datasource Location.
    3.  Set Datasource Location window will appear and in the replace with  section connect to the database and replace these tables with the tables  in the current Datasource by clicking the update button.
    4. After updating close the Set Datasource Location window.
    5. Go to 'Database menu' and Click 'Verify Database' and click on ’OK’.
    6. Preview the report and the save the report.

    NOTE: Global Support Services no longer support Crystal Reports, if  further assistance is needed on this issue please contact your Certified  GoldMine Solutions Partner.