Rehost Failed!  Error: Failed to open file C:\GoldMine\Common\CONTUDEF.dbf - When rehosting dBase data getting error: Failed to open file *.dbf

Version 1

    Details

    Rehost Failed!  Error: Failed to open file C:\GoldMine\Common\CONTUDEF.dbf - When rehosting dBase data to SQL




    [ADDITIONAL NOTES]

    - This may reference to any related files from the contact set, GMBase or system dbf files during the rehost.


    Resolution

    [CAUSE]
    - The specific files are either
    a. Missing in the specific location
    b. The windows user does not have sufficient rights to the specific file(s).
    c. The files were originally opened at one point with Microsoft Access which adds also identical files with an *.INF extension. for example
    CONTACT1.DBF, CONTACT1.MDX, CONTACT1.DBT and CONTACT1.INF or in above example CONTUDEF.DBF, CONTUDEF.MDX and CONTUDEF.INF (there might be also the related Microsoft Access file CONTACT1.MDB or CONTUDEF.MDB)




    [RESOLUTION]
    1. Cancel the rehost
    2. Browse out to the path referenced in the error ( for example above C:\GoldMine\Common\)
    3. Remove all files that end in the extension of .INF (While it might be considered also to remove any *.MDB files only the *INF files are causing the error message)
    4. Verify that full control is give to the groupname 'Everyone' for this entire path including subdirectories
    5. Go through the steps to rehost again