Auto dial feature does not work for international numbers,it drops the 0 when dialing

Version 1

    Details

    Auto dial feature does not work for international numbers,it drops the 0 when dialing


    Resolution

    NOTE: even if you select the radio button in Edit>>Record Properties>>Record Related Settings to "Non-USA Format" and you select to create a "New Contact", it will not check the "International Phone Format" box by default if your regional settings Format  in Windows is set to English (United States). You have to check that box manually and click OK and then the Contact1.Status field should have an 'I' as the first character to indicate that it is an International formatted contact record. 'U' as the first character in the Contact1.Status field indicates that it is a USA formatted contact


    - If you want to change the Phone format of an existing contact, you would need to have that contact record opened and then go to Edit>>Record Properties>>Record Related Settings and select "Non-USA Format" from the Phone Formatting tab. 

    NOTE: If you add the Contact1.Status field to the contact record screen so this can be easier to see while you are on the contact record instead of querying the database.
    IMPORTANT NOTE: If you leave this field on the screen you must NOT change any value in this field manually only through Edit>>Record Properties>>Record Related Settings as this is not meant to be changed manually

    Result: Now the Auto-dialer will dial the international phone number as expected without dropping.