GoldMine crashes when NUANCE PDF (Advanced) is installed and is a default handler for PDF files - after error Failed to load application resource 'ZeonForm.zxt' (internal error).

Version 1

    Details

    GoldMine crashes when NUANCE PDF (Power PDF Advanced) is installed and is a default handler for PDF files - after error Failed to load application resource 'ZeonForm.zxt' (internal error).

    [PRE-REQUISITES]
    1.  Having NUANCE PDF installed and being the default handler for PDF files

    [STEPS TO REPRODUCE]
    1. Browse to Art Bardtoll
    2. Links Tab
    3. Make sure that the preview pane is visible
    4. Right click > New
    5. Browse to the GoldMine shared folder and select the EULA.pdf and provide any document name



    6. OK
    7. In trial mode you have to confirm to use NUANCE PDF in trial mode)

    [RESULT]
    - The link seems as being created
    - And GoldMine tries to preview the file but it seems the Nuance PDF is  incompatible with the preview applet and an error message appears -  Failed to load application resource 'ZeonForm.zxt' (internal error).



    - Pressing OK on the error will bring the arrow at least 2 further  related errors referencing again ZeonForm.zxt and then ZDigSig.zxt files  and then GoldMine crashes



    -  The event viewer shows a BEX error (which refers usually to Data  Execution Prevention errors)  but trying to get NUANCEPDF.Exe into the  exclusion brings an error message that this application MUST run with  DEP (set DEP to essential Windows programs and services does not change  the behavior) also changing DEP to AlwaysOff

    [ADDITIONAL NOTES]
    - The same applies when adding pdf files to Opportunity/Project, Details tab and Case Attachments


    Resolution

    [CAUSE]
    - This is RM # 237169

    [WORKAROUND]
    A. Disable the preview (by minimizing the window with the >> chevrons) - which will help only temporarily as once the  preview is opened and by accident a PDF is selected GoldMine will crash  again





    B. Disable PDF files from the Preview settings via
    1. Log in as user with master rights
    2. Tools > Configure > System Settings
    3. Preview Tab
    4. Highlight Nuance Power PDF Document (pdf)



    5. Delete
    6. Now the preview is disabled for PDF files and the error does not occur anymore