Error: "A problem occurred while attempting to launch the Task on the client" when pushing a Power Management policy

Version 9

    Verified Product Versions

    Endpoint Manager 9.5Endpoint Manager 9.6Endpoint Manager 2016.x

    Issue

     

    Error: "A problem occurred while attempting to launch the Task on the client" when pushing a Power Management policy.

     

    In the task log, the error code "-2147483646" may show after the REMEXEC statement.

    Or in the console you see the error 'An internal error has occurred' return code 1208

     

    Cause

    This error occurs when the Power Management Agent has not been included in the LANDesk Agent when the LANDesk Agent was deployed to the client.

     

    If an agent was updated to the Service Pack by using the Patch, this does not ADD agent components that were not there to begin with.

     

    Resolution

    Check the box for the "Power Management" agent in the Agent Configuration as pictured below and then push the Agent Configuration to your faulting clients.

     

    After pushing the Agent Configuration to your clients, try to push the Power Policy again.

     

    powermanagementagent.jpg