Creating a Contact Group from the Contact Search Center makes the group much larger than the results shown in Contact Search Center.

Version 1

    Details

    - When Creating a Contact Group from the Contact Search Center makes the group much larger than the results shown in Contact Search Center.
    - Previously tagged records are not released (and no message appears that they are still tagged) when changing the search criteria >> Adding to contact group will result in more than expected records


    [PREREQUISITE]
    Using GoldMine Demo Database which has 7 contacts created in 2005 and 7 contacts created in 2006

    [STEPS TO REPRODUCE]
    1.  Go To>>Search>>Contact Search Center
    2.  Search by:  Createon Greater or Equal 1/1/2005  (click + sign)
         AND            Createon  Lesser or Equal 12/31/2005
    3.  Seven contacts display
    3.  Right-click in the list and select Tag All
    4.  Click Add to, and select New Contact Group
    5.  Give the group a name and click OK
    6.  Click OK on the Add a Group Member prompt
    7.  Tools>>Groups

    [EXPECTED RESULT]

    [ACTUAL RESULT]
    Same as Expected Result

    8.  In the Contact Search Center tab, replace both 2005s with 2006
    9.  Seven contacts display
    10.  Right-click in the list and select Tag All
    11.  Click Add to, and select New Contact Group
    12.  Give the group a name and click OK
    13.  Click OK on the Add a Group Member prompt
    14.  Click on Filters and Groups tab

    [EXPECTED RESULT]

    [ACTUAL RESULT]

    [NOTE]
    It appears results from the 2005 search were merged in with the 2006 results when the 2006 group was created.

     


    Resolution

     

    [CAUSE]
    - Previously tagged  records are not released (and no message appears that they are still  tagged) when changing the search criteria. This means that the previously tagged records are added to the contact  group which results in more than expected in the group.
    -This is logged as RM #239734


    [WORKAROUND]
    Before starting the second, and subsequent searches, un-tag the results from the previous search.

    - Right-click in the results list of the Contact Search Center
    - Select 'Release All'