Attempt to link an Email to a contact - the upcoming Contact Search Center (CSC) dialog hangs or freezes

Version 1

    Details

    Attempt to link an email to a contact - the upcoming Contact Search Center (CSC) dialog hangs or freezes

    - Attempt to link an email to a contact
    - Contact Search Center opens with Search by:  Record Type Equal to (default type), and hangs or freezes 
    - Trying to exit Contact Search Center causes GoldMine to hang or crash with the Close the program or Wait for the Program to respond message




     


    Resolution

    [CAUSE]
    - Due to the nature of being the 'default record type' the search has to consider very many records especially when the GoldMine database contains a large amount of contact records, this causes a performance bottleneck and may result in a non-responding mode or even crashing.

    [RESOLUTION]
    - Restart GoldMine and choose one of the following options


    [OPTION 1]
    - Tools > Options > Lookup tab
    - For Default lookup by field:, select either Contact: or Company:

    - Click OK

    [OPTION 2]
    - If you want Default lookup by field: set to Remember Lookup By
    - Open a contact and double-click a label (for this example, Contact) to open the Contact Search Center with Search by: set to that field



    - Close the Contact Search Center

    [AFTER PERFORMING ONE OF THE ABOVE OPTIONS]
    - In the E-mail Center attempt to link an email to a contact



    - The Contact Search Center opens with Search by: set to Contact (or Company)



    - You can now successfully search for the desired contact, and link the Email to it