If the F2 Lookup list contains more values as the set display limit in the System settings >> the Edit, Delete and Select button get greyed out when you scroll beyond the set limit

Version 1

    Details

     

    If the F2 Lookup list contains more values as the set display limit in the System settings >> the Edit, Delete and Select button get greyed out when you scroll beyond the set limit

    [STEPS TO REPRODUCE]
    these steps are only to demonstrating the behavior a real life scenario will usually be that the amount of lookup entries are much more for example 1000 (the login customer has even 14000 entries in one F2 Lookup field)
    1. Login as a user with master rights
    2. Tools >> Configure >> System Settings
    3. Tab Display
    4. Make sure the Limit for maximum records shown as default 500

     5. OK
    6. Browse to Bea Defkow
    7. F2 into Country to open the Lookup list
    8. scroll to the end of the list United Kingdom
    9. Try the Edit button (or Delete or Select button)
    >> RESULT: The button works as expected and is still available

    10. Tools >> Configure >> System Settings
    11. Tab Display
    12. Change the Limit for maximum records shown as to 10

    13. OK
    14. Browse to Bea Defkow
    15. F2 into Country to open the Lookup list
    16. Scroll until to get over the limit (first you will see only up to Mexico but then after overcoming the limit you see also United Kingdom)
    17. Try the Edit button (or Delete or Select button)
    >> RESULT: The button will grey out and the user does not have a chance to edit, delete or select a value (select works with a double click on the value)



     


    Resolution

    [CAUSE]
    - The reason is that only the first x rows for  the F2 Lookup list are loaded into the F2 Lookup window determined by the setting in Tools > Configure > System Settings > Tab Display, once the limit is overcome by scrolling beyond it, the behavior occurs.
    - This is RM # 234082


    [WORKAROUND]
    Raise the limit for shown records via the System Settings

    Set  the Limit  appropriately which is expected not to affect the system's performance  too much but cover such Lookup lists, GoldMine Technical  Support is aware as an average for such large F2 Lookup List that there are more  than 1000 but less then 1500 entries available, so considering the  overall performance of GoldMine as this setting also affects most other  lists within GoldMine a set limit of 1500 might be a reasonable. Where the amount of F2 values is really much larger we do not recommend to set the limit much higher.



    1. Login as a user with master rights
    2. Tools > Configure > System Settings
    3. Tab Display
    4.  Set the Limit for maximum records shown appropriately for example to  1000 or 1500 (while we think that values of 1000 or 1500 should be still  not have impact on the overall performance any higher values need to be  tested and considered carefully)



    5. OK
    6. Browse to Bea Defkow
    7. F2 into Country to open the Lookup list

    [RESULT]

    As now it is not necessary anymore to scroll beyond the limit the Edit, Delete and Select buttons are not greyed out anymore

     

    Additional Notes: If there a much higher number of F2 Lookup values then the temporary workaround would be to raise the limit for the maintaining of the F2 lookup list and then set it back to an acceptable value