iGoldMine 2014.2 HF1/iGoldMine 2015.1 both including all available patches - Application Publishing Service (APS) will not start after the Microsoft updates released on 13th September 2016 - KB3185911 on Windows 8.1 and Windows Server 2012 R2

Version 1

    Details

    iGoldMine 2014.2 HF1/iGoldMine 2015.1 both including all available patches - Application Publishing Service (APS) will not start after the Microsoft updates released on 13th September 2016 - KB3185911 on Windows 8.1 and Windows Server 2012 (R2)


    - After restarting the iGoldMine Application Service the following error occurs

    Windows could not start the iGoldMine Application Publishing Service on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 3687.



    - The related APS log file shows an error:

    APS log shows: 37 2016-09-22 10:15:07.300  aps (1424) The version of Win32k.sys on this installation of Windows is incompatible with (null).


     


    Resolution

    [CAUSE]
    - We have identified an issue ONLY on iGoldMine 2014.2 and iGoldMine 2015.1 (please keep in mind that any older iGoldMine versions are not tested) where the iGoldMine Application Publishing Service fails to start after applying Windows updates KB3185911


    [INFORMATION]/[RESOLUTION]

    iGoldMine 2016.1 is NOT affected and it is recommended that affected customers upgrade to iGoldMine 2016.1 

    iGoldMine 2016.1 is available for download from the Self Service Portal and it is highly recommended that impacted customers will install this new version iGoldMine 2016.1 in order to address the incompatibility with Microsoft 
    KB3185911. Please keep in mind that depending from your original iGoldMine version it might be necessary to request a new license, please refer to Knowledge Article # 
    17853 : How to relicense iGoldMine after iGoldMine has been rehosted, reinstalled, or moved to a different server 



    [WORKAROUND]
    - If customers need due to any reason to stay on iGoldMine 2014.2 or iGoldMine 2015.1, then the only solution is to uninstall KB3185911 from Control Panel >> View Updates History >> Installed Updates >> Right Click on Security Update for Windows xxxx (KB3185911) >> Uninstall >> After the uninstall a restart of the machine is required. please keep in mind that this affects only Windows 8.x and Windows Server 2012 (R2)