When a new Hot Fix is released for GoldMine Premium Edition 2015.2, the installation package contains always the GMPE 2015.2 Hot Fix installer and also the GMConnect 2015.2 Hot Fix installer. Do I need to apply the Hot Fix always on both applications?

Version 1

    Details

    When a new Hot fix is released for GoldMine Premium  Edition 2015.2, the installation package contains always the GoldMine  Premium 2015.2 Hot Fix x installer and also the GoldMine Connect 2015.2  Hot Fix x installer.
    Do I need to apply the Hot Fix [x] on both  applications?

    While upgrading GoldMine Connect is rather simple  and can be applied

    a. On top of any existing GoldMine Connect 2015.1.x/GoldMine Connect 2015.2.x installation (please also always to the  specific Release Notes of the version/ Hot Fix that nothing has changed)
    b. Requires only the following steps (please also always to the  specific Release Notes of the version/ Hot Fix that nothing has changed)

    Note: Run the GoldMine Connect 2015.2 HF1 installer for a new installation or to upgrade GoldMine Connect 2015.1 or newer. If you are upgrading from a version of GoldMine Connect previous to 2015.1, it is
    necessary to uninstall the existing version of GoldMine Mobile or GoldMine Connect and install GoldMine Connect 2015.2 HF1 as a new installation.
    It is recommended to clear device/browser cache and to restart IIS after uninstall/reinstall or upgrade of GoldMine Connect. 

     

    Usually we recommend additionally to make prior the upgrade backups of the
    - GoldMine Connect folder
    - Your IIS configuration
    - Other published Web Sites

    - After the new installation of GoldMine Connect, make sure to apply any desired changes again to the Web.config file for GoldMine Connect. 
    - The  upgrade of GoldMine Premium Edition means much more effort as it  requires to upgrade first the application server, then all networked clients and  all remote clients like other sites and undocked users.
    - Is it  necessary to upgrade both applications - GoldMine Premium Edition and  GoldMine Connect - at the same time to the same Hot Fix level?

    The following scenarios could be examples in which cases the question may arise if only the GoldMine Connect  application needs to be installed/upgraded but not the GoldMine Premium  Edition application:

    Scenario 1:

    a. Current situation customer's GoldMine system
    -  GoldMine Premium Edition GA release 2015.2.0.159 is installed and  rolled out to all clients and remote systems, no issues are reported or  experienced
    - There is NO LOOKUP.INI in place triggering Ownership and Record curtaining for new created contact records
    - So far no GoldMine Connect available but shall be setup now. 

    b. The following GoldMine Premium Edition installers are offered
    - GoldMine 2015.2 GA Release
    - GoldMine 2015.2 Hot Fix [x]

    Which version of GoldMine Connect can be installed?
    When choosing to  install the latest version, hot fix x of GoldMine Connect 2015.2 is it necessary  to upgrade also the current GoldMine Premium Edition 2015.2 GA-release system to GoldMine Premium Edition 2015.2 Hot Fix [x]?

    Scenario 2:
    a. Current situation customer's GoldMine system
    -  GoldMine Premium Edition GA release 2015.2.0.159 is installed and  rolled out to all clients and remote systems, no issues are reported or  experienced
    - There is a LOOKUP.INI in place triggering Ownership and Record curtaining for new created contact records
    -  So far no GoldMine Connect available but shall be setup now.
     
    b. The following GoldMine Premium Edition installers are offered
    - GoldMine 2015.2 GA Release
    - GoldMine 2015.2 Hot Fix [x]

    Which version of GoldMine Connect can be installed?
    When choosing to  install the latest version, hot fix x of GoldMine Connect 2015.2 is it necessary  to upgrade also the current GoldMine Premium Edition 2015.2 GA-release system to GoldMine Premium Edition 2015.2 Hot Fix [x]?

    Scenario 3:

    a. Current situation customer's GoldMine system
    -  GoldMine Premium Edition 2015.2 Hot Fix 1 (release 2015.2.0.159) is installed and rolled  out to all clients and remote systems
    - GoldMine Connect 2015.2 Hot Fix 1 (release 2015.2.0.348) is installed

    b. The following GoldMine Premium Edition installers are offered
    - GoldMine 2015.2 GA Release
    - GoldMine 2015.2 Hot Fix [x] - HF 2 or higher

    c. While reviewing the release notes for GoldMine 2015.2 hot fix x the GoldMine administrator recognizes that
    - Only certain GoldMine Premium Edition Email client issues/changes were made but the GoldMine Premium Edition Email client is not used at all in the current customer setup  
    -  Further more only GoldMine Connect (GoldMine Web or GoldMine Mobile)  issues or changes were made which would be helpful and necessary on the  current customer setup

    Can the GoldMine Connect 2015.2 Hot  Fix [x] - HF2 or higher - be installed separately from the current GoldMine Premium  Edition 2015.2 hot fix 1 system?

    Scenario 4:
    a. Current situation customer's GoldMine system
    -  GoldMine Premium Edition 2015.1 Hot Fix 3 (release 2015.1.0.196) is installed and rolled  out to all clients and remote systems
    - GoldMine Connect 2015.1 Hot Fix 1 (release 2015.1.0.367) is installed

    b. The following GoldMine Premium Edition installers are offered
    - GoldMine 2015.1 Hot Fix 4
    - GoldMine 2015.1 Hot Fix 5
    - GoldMine 2015.2 GA
    - GoldMine 2015.2 Hot Fix [x]

    c. While reviewing the release notes for GoldMine 2015.2 GA or Hot Fix [x] the GoldMine administrator recognizes that
    - Only GoldMine Premium Edition issues/changes were made which are not reported to be experienced by current users   
    - GoldMine Connect (GoldMine Web or GoldMine Mobile)  issues or changes were made which would be helpful and necessary on the  current customer setup

    Can the GoldMine Connect 2015.2 GA or Hot fix [x[ be installed separately from the current GoldMine Premium  Edition 2015.1 hot fix 3 system?

     


    Resolution

    - Usually it is not necessary to upgrade always both  applications - GoldMine Premium Edition (GMPE) 2015.2.x and GoldMine Connect 2015.2.x - in  tandem when a new Hot fix is released, see below for any exceptions.

    - The only base requirement for both applications is that the major version do match, this means
    GoldMine Premium Edition (GMPE) needs to be on any official build of the major version 2015.2 and
    GoldMine Connect needs to be on any official build of the major version 2015.2 (documented in the Compatibility matrix see also related Knowledge Article # 19878)

    -  We strongly recommend to review the related release notes for every  released Hot fix and to determine if an upgrade of only the GoldMine  Premium Edition application, only the GoldMine Connect application or  both applications is necessary or desired on the current GoldMine  system.
    - For the above scenarios this means

    Scenario 1:
    The  customer can install simply the latest Hot Fix version of GoldMine  Connect 2015.2 without needing to upgrade also the current GoldMine Premium  Edition 2015.2 GA release system

    Scenario 2:
    As the  customer does have a LOOKUP.INI in place triggering the Ownership and Record Curtaining when creating contact records the customer needs to install both application's Hot Fix versions, means GoldMine Premium Edition GMPE 2015.2 Hot fix [x] AND GoldMine  Connect 2015.2 Hot fix [x]. The reason for this exception is the fixed RM # 233594 - (GMWEB) - Error, Failed to Create Contact, due to the initial INSERT statement for new records taking over only some fields, causing the LOOKUP.INI already triggering on wrong values. which required changes within GoldMine Premium Edition and GoldMine Connect.
     
    Scenario 3:
    The  customer can upgrade to the latest Hot Fix version of GoldMine  Connect 2015.2 without needing to upgrade also the current GoldMine Premium  Edition 2015.2 Hot Fix 1 system

    Scenario 4:
    -  Although it appears that a GoldMine Premium Edition upgrade would not  be necessary from the GoldMine Administrator's perspective, when wanting  to upgrade GoldMine Connect to any build of 2015.2 also the GoldMine  Premium Edition needs to be upgraded to any build of 2015.2.x as both  applications needs to be on the same base/major version.
    - Any  GoldMine Premium Edition 9.x build and higher can be directly and  within a straight forward process upgraded to any build of GoldMine  Premium Edition 2015.2, means also directly to any 2015.2 Hot fix  without needing to install first the GMPE 2015.2 GA release. Please keep  in mind that for any GMPE 2014.2 build and higher a new license is  required which can be requested from Customer Care team  (mailto:customer.care@heatsoftware.com) without any charge when the  customer is current on maintenance. 
    - Any GoldMine Connect 2014.2  build and lower needs to be uninstalled before any GoldMine Connect  2015.2 build can be installed (see also in description and release notes  of GoldMine Premium Edition/GoldMine Connect 2015.2.x)
    - Any GoldMine Connect 2015.1  build and higher can be directly and  within a straight forward process upgraded to any build of GoldMine Connect  2015.2 (see also in description and release notes  of GoldMine Premium Edition/GoldMine Connect 2015.2.x)
     - Once both  applications are on a 2015.2 base/major version the scenarios 1, 2  or 3 may apply again to any further GoldMine Premium Edition / GoldMine Connect  Hot fixes unless the release notes state something different

    [ADDITIONAL NOTES]
    -  Exceptions may be possible when the Hot Fix contains fixes/changes  related to Google Apps Synchronization and GoldMine Messaging Service