After using the Territory Realignment feature in GoldMine to Globally Replace fields, some fields based on a lookup.ini have not been updated.

Version 1

    Details

    After using the Territory Realignment feature in GoldMine to Globally Replace fields, some fields based on a lookup.ini have not been updated.

    [PREREQUISITES]

    - Lookup.ini like the Example Below

    [AutoUpdate]
    Country=KEY4

    [KEY4]
    Lookup1=Country
    USA=Jason
    United Kingdom=Gary
    Germany=Michaela
    otherwise=Unknown
    Overwrite=1


    - A filter of records to run the Global Replace \ Territory Realignment on.
    - For Example Country Equals UK

    [STEPS]
    1. Tools > Data Management > Territory Realignment...
    2. Select your filter of records
    3. Replace Country with United Kingdom
    4. Select to Reassign the Activities from one user to Another
    5. Finish

    [RESULTS
    ]
    - After the global replace is done you are left with  fields that have incorrect data as the lookup.ini has not been  triggered.


    Resolution

    [CAUSE]
    The Territory Realignment feature does NOT ask you to Update linked Fields (based on Lookup.ini) this means that after the global replace is done you are left with fields that have incorrect data as the lookup.ini has not been triggered.

    [RESOLUTION \ WORKAROUND]
    - Perform a Global Replace to trigger the Lookup.ini
    1. Tools > Data Management > Global Replace
    2. Replace a field with a value
    3. Replace Country with United Kingdom
    4. Tick the box Update linked Fields (based on Lookup.ini)
    5. Select your filter of records
    6. Finish