Problem / Solution: During upgrade, the MDM does not create Shortcut Groups for new features and runs into an error

Version 1

    Verified Product Versions

    LANDESK Service Desk 7.8.xLANDESK Service Desk 2016.xLANDESK Asset Central 2016.xLANDESK Service Desk 2017.x

    Environment:

    Service Desk / Asset Central 2016.1

    Service Desk / Asset Central 2016.2

    Service Desk / Asset Central 2016.3

    Service Desk / Asset Central 2016.4

     

    Requires Access To:

    Configuration Center - Framework upgrade

    Database Server

     

    Error message:

    Cannot insert the value NULL into column 'ui_index', table '<DB_Name>.dbo.ui_shortcut_item'; the column does not allow nulls. INSERT fails. The statement has been terminated.

     

    Problem:

    The shortcut groups needed by the MDM to successfully upgrade, are not created by MDM in a prior step and the operation aborts with the above error.

     

    Cause:

    This has been identified as the problem 6662 - During Upgrade MDM does not create Shortcut Groups for new features and runs into an error

     

    Solution / Workaround:

    The above problem is currently planned for a fix in 2017.3, but in case of any urgent fix please find attached to this document some SQL scripts to solve it.

     

    Instructions

    1. Perform a backup of your Database before running any of these script
    2. Run every script for every version up to and including the current version but none for any version after that.
      For example, if the your version is currently 2016.3 please run as follows:
      1. MDM script re-runs 2016.1.sql

      2. MDM script re-runs 2016.2.sql

      3. MDM script re-runs 2016.3.sql

    3. If you encounter any issue running these scripts, please restore the backup performed in 1. and report this on our support portal and mention this article as a reference.