Problem / Solution: An import mapping is not visible anymore. How to recover it?

Version 6

    Verified Product Versions

    Service Desk 7.7.xService Desk 7.8.xService Desk 2016.xAsset Manager 2016.xAsset Manager 2017.xService Desk 2017.x

    Requires Access To:

    Service Desk Console

    Database Server

     

    Problem:

    We configured some imports in the Service Desk Console but it disappeared.

     

    Cause:

    The XML file (stored in the database) which defines the import mapping has been corrupted. Some part of XML tags could have been removed.

     

    Solution:

    It's possible to recreate the mapping using the information stored in the table tps_application_setting.

     

    1. Search for the missing mapping in the table tps_application_setting using the following statement:

    SELECT * FROM tps_application_setting
    WHERE tps_name LIKE 'DataImportConfig%'
    AND tps_value LIKE '%<Name of your Mapping%'
    

      Replace the tag <Name of your Mapping>  by the name of the missing data import mapping

     

    2. When you localised the mapping, copy paste the information from tps_value column to a text editor. It contains the import mapping XML definition.

      Tip: Use Notepad ++ and format it as XML. Then you will be able to retrieve your mapping definition and re-map them within the Service Desk console. You can as well use the "XML Tools" plugin of the Notepad ++ to visually format the XML tags to be read more easily.

     

    3. After that, you can delete the corrupted mapping identified in 1. from the database using a DELETE statement.

     

    Example:

    The example below shows a mapping called "New Import Mapping" on the End User object. It just maps the Name and Title of users from an Excel sheet to the Service Desk users. The XML result stored in "tps_value" is attached to this article as an example.

    We can see the mapping definition through the "sourceAttribute" and "targetAttribute" tags.