Server Error - Login failed for user 'sa' - GoldMine.Models.ApplicationExceptions.ClientInformationException: Login failed for user 'sa'. - when trying to login to GoldMine Web.

Version 1

    Article Description

     

    - After keying user credentials on GoldMine Web login page, the following error happens:

    Login failed for user 'sa'

    - The GoldMine Connect log shows:

    GoldMine.Models.ApplicationExceptions.ClientInformationException: Login failed for user 'sa'.

     

    Article Resolution

    NOTE: There can be two different root causes to this problem and in some cases both root causes need to be addressed.

    - Root cause #1 - IIS does not have the proper access to the GoldMine Share.

    - Root cause #2 - SQL 'SA' credentials are populated in the GoldMine User Settings > Properties > Access tab.

     

     

    Cause#1:

    1. Set GoldMine Mobile Application Pool in IIS as a Domain Administrator by:

    a. Open IIS Manager.

    b. Right-click on the GMMobileAppPool application pool.

    c. Select Advanced Settings, then Process Model > Identity.

    d. Click the ellipses button (...) next to ApplicationPoolIdentity.

    e. Select the Custom account radio button.

    f. Click Set.

    g. Enter the Windows User name (e.g., gmmobile) and Password.

     

    NOTE: The User name/Password combination must be the same in all locations where the User (Example gmmobile) is added.

     

    2. Perform an IIS reset.

    3. Test the result.

     

     

    Cause #2:

    1. Log user out of GoldMine.

    2. Login to GoldMine as a user with MASTER rights.

    3. Click Tools > Users Settings > Highlight user > Properties > Access tab.

    4. Remove credentials under "SQL Logon name:" and "SQL Password:" > OK > close.

    5. Perform IIS reset.

    6. Test the result.

     

     

    NOTE: The steps for root cause #2 are on a per user basis.