When attempting to deploy new Netscan IP Ranges to a Gateway the Agent Task never appears in the Gateway workspace and the Error Message appears: "GetClientTasks: [...] reason=An invalid IP address was specified" in the Logs workspace.

Version 1

    Environment:

    HEAT Discovery enabled SM tenants (Cloud or Premise)

     

    Requires Access To:

    Tenant Logs Workspace

     

    Error message:

    Service Name: IM

    Error Code: FaultException

    Log Severity: FATAL

     

    Exception

    System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: An invalid IP address was specified....

     

    Message

    GetClientTasks: FaultException: clientId=[...], clientAuthenticationKey=[...], xmlArguments=[...], reason=An invalid IP address was specified., source=mscorlib, errors=An invalid IP address was specified.An invalid IP address was specified.

     

     

    Problem:

    When attempting to deploy new Netscan IP Ranges to a Gateway the Agent Task never appears in the Gateway workspace and the Error Message detailed above appears in the Logs workspace.

     

    Cause:

    This is caused when the IP Address, IP Range or Subnet does not match the specified format.  The acceptable formats are detailed on the "New IP-Range" dialog:

    IP-range can be entered in following formats: 192.168.1.1-192.168.1.254 or 192.168.1.0/255.255.255.0 or 192.168.1.0/24

     

    Solution / Workaround:

    Double check for typos or Ranges that do not follow the specified formats.  Once corrected, re-click the Deploy Settings button.