Options on the menu tab bar are grayed out when removed from the user settings.

Version 4

    Hint: The issue can be replicated when creating a new user in GoldMine. Please be sure that you are logging in with a proper UserID.

    If you'll log in with the existing userID all the options should be  removed.

    The .ini file must has the same name as the user that you want to use. For ex. if the userID is Test the .ini file in GoldMine will be named Test.ini.

    This is what i get when logging in as an existing user who logged into the system before.

     

     

     

    schedule good2.png

     

     

     

     

     

    This is a view of a user that never logged into the system before.

     

    schedule good1.png

     

    To replicate please:

    First log into GM as a Master user then please go to users settings in the Tools tab in the main menu.

    Then please double click on the affected user that can not see the mentioned options in the schedule menu.

    After that please go to the Menu tab. Right here please select schedule(and expend it by clicking in the plus sign).

    After that click the options that are marked with the red pin so they will turn green.

    After all the steps above are completed please log out as a Master and log back in. Then please do the same steps but turn the options that you have turned to green in previous steps back to red.

    After that log out as a Master user and log in with the user profile. After that the options in the schedule bar should not be visible any more and also they should not be grayed out.

     

    The workaround for this behavior:

    1. log out as the impacted user

    2. log in with master rights

    3. enable the menu settings again

    4. let the user log in again

    5. verify that the menu items are there and not grayed out

    6. log out as the impacted user

    7. log in with master rights

    8. disable the menu settings again for the user

    9. verify as the user