Incomplete User Profiles in combination with VMware View

Version 1

    Problem

    In VMware View there is the option to Reset, Refresh, Recompose or Rebalance a machine.

    If the "Reset" option is used while users are still logged on the user might have an incomplete profile the next time they log on.

     

    Cause

    The reset option in VMware View just resets the virtual machine without shutting down the operating system properly like it does when clicking the reset option in VMware vCenter. The user session will be disconnected and all unsaved work will be lost.

    In this scenario the session is forcefully closed and RES Workspace Manager is unable to perform it's logoff tasks.

     

    Solution

    Not related to RES Workspace Manager.

    Because the session has been reset RES Workspace Manager is unable to detect where it left off.

    Workaround:

    If possible Refresh or Recompose the virtual machines instead of resetting them.

    When refreshing a desktop or a pool of desktops, you are basically bringing that Virtual Machines delta disk back into sync with the parents currently selected snapshot.