Microsoft Windows eventlog shows actrpt2.dll error when running an Active Report

Version 1

    Problem

    Microsoft Windows Eventlog shows actrpt2.dll error when running an Active Report.
    This error can be generated by third party software like AFAS Profit or any other application that uses Active Reporting. 


     

    Cause

    RES ONE Workspace uses Active Reporting for creating an Instant Report from the RES ONE Workspace Console. 
    Other vendors may integrate Active Reporting in their software too. This may result in version conflicts when these vendors apply different version of Active Reporting then RES ONE Workspace does.


     

    Solution

    In RES ONE Workspace V10, RES implemented the latest versions of Active Reporting components.
    These files are normally stored in C:\Program Files (x86)\RES Software\Workspace Manager\AR2\.

    Applications containing an older version of Active Reporting might overwrite newer versions of Active Reporting when deployed.
    Make sure alle installed applications using Active Reporting support the same version of Active Reporting.

    The Active Reports files being updated are:
    pdfexpt.dll
    actrpt2.dll
    arview2.ocx
    htmlexpt.dll