A RES ONE Workspace agent cannot switch to a RES ONE Workspace Relay Server in another site

Version 1

    Problem

    Consider the following scenario:
    • An infrastructure consists of multiple sites.
    • All sites have their own RES ONE Workspace Relay Servers.
    • A RES ONE Workspace Relay server cannot be contacted from another site.
    • A RES ONE Workspace agent is configured to use a RES ONE Workspace Relay Server based on a zone that can identify the site.
    • The RES ONE Workspace agent is connected to a RES ONE Workspace Relay Server in the first site.
    • The machine is moved to a second site.
    In this scenario the RES ONE Workspace agent is started, but cannot connect to the RES ONE Workspace Relay Server in the second site.

    As a result the cache is not updated until the it is moved to the first site again.


     

    Cause

    The RES ONE Workspace agent will keep trying to connect to the RES ONE Workspace Relay Server in in the first site.

    If the RES ONE Workspace Relay Server in the first site could be reached, then the RES ONE Workspace agent would be able to connect to the RES ONE Workspace Relay Server in the second site.

    The expected behavior would be that the RES ONE Workspace agent will connect to the RES ONE Workspace Relay Server in the second site without making an initial connection to the RES ONE Workspace Relay Server in the first site.


     

    Solution

    This issue is resolved in RES ONE Workspace 10.2.0.0.

    In case the Minor Release is not (yet) available, or in case the Minor Release cannot be installed, contact Ivanti Support to obtain more information on the availability of a Revision.

    IMPORTANT: A revision contains multiple fixes. Only apply this revision when you are experiencing a specific problem. Unless you are severely impacted by this specific problem, Ivanti recommends that you wait for the next Minor Release containing these fixes.