Users can't login to a RES ONE Workspace managed session due to  a crashing Winlogon.exe with faulting module PicaWinlogonHook64.dll

Version 1

    Problem

    Consider the following scenario:
    • Citrix virtual desktop agent 7.6.300 or 7.7.
    • Microsoft Windows 7 64bit or Microsoft Windows 10 (RTM version 10240 or 1511 version 10586) operating system.
    • RES ONE Workspace Agent is installed and the image is rebooted.
    In this scenario the logon screen does not appear, but the mouse cursor blinks indefinitely.

    Connecting to the agent's Microsoft Event Viewer displays many entries for Application error: Winlogon.exe crashing due to faulting module PicaWinlogonHook64.dll
    If the RES ONE Workspace Agent is uninstalled via safe mode, the error persists.


     

    Cause

    This issue is caused by Microsoft Updates.

     

    Solution

    Citrix has released a hotfix for this issue that replaces the PicaWinlogonHook64.dll among other files.

    This is descibed in the following Citrix article:


    http://support.citrix.com/article/CTX205784